Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Configuration problem affecting Mollom

Go to End



Community Member, 14 Posts

6 February 2010 at 12:37am


I am having an issue with mollom on several websites that I manage. The websites are hosted on different web hosts.
Since last week, I am getting the message below from mollom. Did someone else also experienced this issue? Can someone help me?

"We just noticed that something might be wrong with your server configuration at XXX.

Your site is sending invalid IP addresses to the Mollom servers. Mollom uses IP address information to maintain IP address reputations, and uses those reputations to help block spammers. Because your site is sending us invalid IP addresses, Mollom is less effective in blocking spam on your site. Sending Mollom the right IP addresses is important, so we highly recommend that you look into this problem. I included some technical details below.

In most situations, this problem is caused by the fact that your site is running behind an HTTP accelerator (e.g. Varnish), a reverse proxy (e.g. Squid), a load balancer (e.g. Nginx), or a content delivery network (e.g. Akamai). When one or more of those are incorrectly configured, the Mollom plugin installed on your site will send internal IP addresses (e.g., or any other LAN address) instead of the actual IP addresses of your site's visitors. It is important to send the visitor's IP address so make sure things are properly configured.

In addition, content management systems like Drupal provide a configuration setting that should be used to instruct Drupal about the fact that your site is running behind an HTTP accelarator, a reverse proxy or a load balancer. This is an explicit setting to prevent IP spoofing attacks -- if you don't configure your content management system correctly, it will continue to use the wrong IP address. That or your site is vulnerable to IP spoofing attacks and that is affecting Mollom's efficiency on your site. Make sure that you upgrade to the latest version of the Mollom plugin, and that your content management system is configured properly because it will affect more than just the Mollom plugin. (If you are using Drupal 6 or later, search your settings.php file for 'reverse_proxy'. If you are using Drupal 5, you need to make some custom changes to your setup.)

If you have questions about Mollom, suggestions for improvement, or if we can offer any assistance please don't hesitate to contact support at When you do, please mention your site's public key (XXX).