Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Multisite on SS V3.2.1


Go to End


3 Posts   1530 Views

Avatar
beeman

Community Member, 3 Posts

31 December 2015 at 4:55am

Edited: 31/12/2015 4:56am

Hello all,

I'm a newbee to SilverStrip CMS and gone through a big learning curve so far getting the Composer installed etc.

I intend using some kind of multisite addon that will allow me to have folders with subsites on the same domain. Looking at the two options these addons want a higher release version than I have installed unless I'm not understanding the requirements properly. I tried to install them with Composer but both failed.

Any ideas how I should proceed?

Kind Regards, Steve

Avatar
beeman

Community Member, 3 Posts

1 January 2016 at 1:33am

Update installing Multisite

Well I managed to install with composer "composer require silverstripe/subsites" leaving out the "dev-master" on the command line and the module installed without any errors. The instructions say use the domain/dev/build and you should notice the multisite table has been created and then the multisite option will appear on the SilverStripe CMS menu but it looks the multisite table hasn't been created.

Anybody got any ideas?

Kind Regards, Steve

Avatar
Lexandclo

Community Member, 55 Posts

7 January 2016 at 4:29am

Is there a table in the database called ' subsides ' ?