Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

User Form Module not working in online demo as well as on installed version

Go to End

5 Posts   1925 Views


Community Member, 2 Posts

8 March 2010 at 10:07pm

Edited: 08/03/2010 10:16pm


I tried the online demo of user form. When i click on form tab & then click on add after selecting a field it shows "Error creating field". I am unable to find out the reason. I have also installed latest version of silver stripe i.e 'SilverStripe-v2.3.6' along with the user form module. But the problem still exists.
Please help me on this how can i resolve this issue.



Community Member, 16 Posts

9 March 2010 at 10:45pm

I have the same problem with 2.3.6 and the newest UserForms ...
Tried different version of UserForms ... it works somehow - but it's not the way i want it (errors after filling the form).

Any ideas ?


Community Member, 16 Posts

9 March 2010 at 11:56pm

I have the answer !!

Here you will find solution :

The easiest way to fix this you need to go into PHPMyAdmin, select your database, select the 'EditableFormField' table on the left, Select the 'Structure' tab in the main part then delete the 'CustomParameter' row in the structure table.

Or you can run the following query on your mysql database (in PHPmyadmin, select the database you're using, then the SQL tab)

ALTER TABLE EditableFormField DROP COLUMN CustomParameter

Got it from Willr, from here :

Hope it helps (it helped me :))


Community Member, 2 Posts

11 March 2010 at 7:43pm


Thanks all for your suggestions.

I have resolved this problem. Actually the version difference between silver stripe and user form were creating problems.
You have to follow these steps:

1) Go to

2) a) In the keyword search enter "user form"
b) In the compatible silverstripe version enter 2.3.6

3) Click search

You will see User Forms [v0.2.1] link. Download this module.

Now follow the steps suggested for enabling user forms.

It will work.



Community Member, 14 Posts

12 March 2010 at 10:19pm


I have recently upgraded SilverStripe from 2.2.3 to 2.3.6. I have installed User Forms 0.2.1 and have the same problem.

If I try to save a form after adding any type of field it comes up with "Server Error" at the bottom LHS where it usually says "Saving..." etc. I can save the page if no fields are added but as soon as I add a field it just won't save.

I have removed the 'CustomParameter' row in the structure table for the 'EditableFormField' table as suggested and unfortunately didn't make a difference.

Any further help would be much appreciated.