Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Generic Views AddForm: Blank page


Go to End


3 Posts   1382 Views

Avatar
dendeffe

Community Member, 135 Posts

17 March 2010 at 5:52am

I'm using generic views for some front end forms. For those who hade the SS book, it's quite similar to that.

I load a Designer that has multiple References. I can edit Designer and References. But when I try to add a button to add References, I can't get it to work. I'm using this in Designer_view.ss:

<a href="/references/Reference/AddForm">Add Reference</a>

It redirects to /references/Reference/85/edit. Martijn explained to me that it automatically creates a new Record.

But it's a completely blank page.

My canCreate for Reference is set like this:

	public function canCreate($member = null) {
		return true;
	}

Avatar
UncleCheese

Forum Moderator, 4102 Posts

17 March 2010 at 6:22am

PHP error.. turn on error reporting and check your syntax.

Avatar
dendeffe

Community Member, 135 Posts

17 March 2010 at 9:14pm

That seems logical, but both my php_error.log and apache_error.log are empty.

I've added my files that I think are relevant.

Attached Files