Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

User Forms 0.3.0 with SS 2.4.0 - Error Creating Field

Go to End

13 Posts   4562 Views


Forum Moderator, 5523 Posts

18 June 2010 at 4:11pm

Edited: 18/06/2010 4:11pm

Ah that ShowOnLoad variable is missing from the $db array. I think it doesn't actually need to be there. Perhaps remove that line from the $defaults array and see if that fixes it.


Community Member, 21 Posts

19 June 2010 at 4:03am

Edited: 19/06/2010 4:20am

Tried commenting out that line, then wiping and rebuilding the database. It doesn't help, I'm still getting the same error. I'm guessing it's because getShowOnLoad() is called in populateFromPostData() on line 269.

So I added "ShowOnLoad" => "Boolean" into the $db array. Now it seems happy.

Is there any reason this might turn out to be a Bad Idea?
Is there a reason this works for other people but didn't work for me?


Community Member, 18 Posts

22 June 2010 at 10:53am

even though ShowOnLoad is not the problem I am having, i tried scpi's solution but i am still getting the same error. i am also wondering why i am getting an error that apparently nobody else is having.

i have gone thru the lines of the error description looking for hints but I am cluless.

i hope i can get this solved soon,



Community Member, 18 Posts

24 June 2010 at 7:10am

So my forum was working properly until I tried to create a Category and I got a similar error (see below) So I guess this is not a problem related to Userforms but rather a SS issue with my server configuration.

I am afraid I am going to keep seeing the same error coming up as I develop my site.

As always, any insight to resolve the problem will be appreciated,



[User Error] Uncaught SS_HTTPResponse_Exception: I can't handle sub-URLs of a Form object.
GET /admin/EditForm/field/Category/add

Line 305 in /hermes/web02/b4/moo.mysitecom/sapphire/core/control/RequestHandler.php

296 /**
297 * Throws a HTTP error response encased in a {@link SS_HTTPResponse_Exception}, which is later caught in
298 * {@link RequestHandler::handleAction()} and returned to the user.
299 *
300 * @param int $errorCode
301 * @param string $errorMessage
302 * @uses SS_HTTPResponse_Exception
303 */
304 public function httpError($errorCode, $errorMessage = null) {
305 throw new SS_HTTPResponse_Exception($errorMessage, $errorCode);
306 }
308 /**
309 * Returns the SS_HTTPRequest object that this controller is using.
310 *
311 * @return SS_HTTPRequest


* RequestHandler->httpError(404,I can't handle sub-URLs of a Form object.)
Line 165 of RequestHandler.php
* RequestHandler->handleRequest(SS_HTTPRequest)
Line 152 of RequestHandler.php
* RequestHandler->handleRequest(SS_HTTPRequest)
Line 147 of Controller.php
* Controller->handleRequest(SS_HTTPRequest)
Line 283 of Director.php
* Director::handleRequest(SS_HTTPRequest,Session)
Line 127 of Director.php
* Director::direct(/admin/EditForm/field/Category/add)
Line 127 of main.php


Community Member, 56 Posts

25 June 2010 at 9:56pm

I have another problem with UserForms 0.3 && ss2.4. DateField is always invalid, whatever I write to it. I'm using 04/01/1981 for example which was ok in erlier versions.

Go to Top