Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

CMS Workflow Installation problems under a SS 2.4 upgrade

Go to End

4 Posts   1286 Views


Community Member, 22 Posts

23 July 2010 at 1:52am

I have recently upgraded my dev box from 2.3.7 to 2.4 and thought I might try and run the cmsworkflow module. I have downloaded it and the legacydatetimefields module and put them both in the root of the application. I have run /dev/build/?flush=1, which seemed to run without any problems.

Now, when I run the /admin and login, I am unable to load any articles instead receiving an error:

Line: 90
Char: 398
Error: 'className' is null or not an object

when using Internet Explorer.

Have I done something wrong?


Community Member, 78 Posts

27 July 2010 at 8:39pm


Is this a javascript error?

What version of Internet Explorer are you using? Have you tried logging into the admin interface with Firefox?



Community Member, 22 Posts

27 July 2010 at 9:01pm

Edited: 27/07/2010 9:02pm

Yes it appears to be JavaScript error.

I am using Internet Explorer 7. When I run it under Firefox I get the little animated circle next to the article name but nothing happens.


Community Member, 22 Posts

8 September 2010 at 2:30am

Guess what? I found the solution....

Because I was upgrading from 2.3.x to 2.4 I still had the jsparty folder. I removed the folder, rebuilt the environment (/dev/build/) and it's all working!