Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Mollom not working on new install [SOLVED]

Go to End


Argentum Studios

Community Member, 5 Posts

25 October 2010 at 7:26pm

Edited: 08/12/2010 8:12pm

I have been setting up a site with SS 2.4.2 and the forum (trunk) module. I finally reached the point of installing the spamprotection and mollom modules. After doing so, the forum registration page results in a blank page in Firefox (no text whatsoever when viewing source) and an HTTP 500 server error page in IE.

However, I am unable to get any sort of error information. My apache logs record nothing at debug error level. I also configured php to use error_log, but no errors are written to it for this situation (I verified it writes errors by purposefully breaking one of my other pages). I've also tried running SS with Director::set_environment_type("dev"); and
Debug::send_errors_to("my address");, which results in nothing displayed on the page or emailed to me.

The closest I get to a real error message is in the CMS admin panel, when going to the Reports section and selecting the Mollom report it simply says Error loading page down in the notification area at the bottom. I have verified my public and private Mollom keys several times. So, I'm at a loss... for now I'm disabling it again, but I would appreciate it if anyone has any thoughts on what may be the issue or even how to get any meaningful information to try tracking down the issue.

Edit: Just as an extra bit of information, when I comment out the Mollom:: and SpamProtectorManager calls in my _config.php the Mollom report doesn't error and instead gives me the message stating that my key hasn't been configured. I can also use my registration form again, so there is definitely something wrong with how Mollom is initializing or running on my system.

Solution: My issue was that I did not have the cUrl module installed for use with php... silly mistake. :)