Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

2.4.3 and image gallery, uploads but broken images in gallery?

Go to End

13 Posts   3555 Views


Community Member, 137 Posts

18 November 2010 at 3:41pm

Edited: 18/11/2010 3:56pm

Hi all,

I am just using 2.4.3, and the latest svn copies of image gallery, uploadify and data object manager.

When I select the image I want to add to the gallery and then it gives me a chance to put a description underneath it I then click continue but then in the gallery the image is broken, like this:

I checked the assets imagegallery folders and my images are there, but obviously when I view the gallery on the front end no images are showing.

I'm not sure if I have to do something else or???

I'm testing locally on WAMP by the way.

Any help would be great


Community Member, 11 Posts

2 December 2010 at 10:44am

Experiencing exactly the same issue here!

SS 2.4.3 - Latest DataObjectManager, ImageGallery, SWFUpload AND Uploadify.

Images seem to upload fine... If I upload for instance 15 images, and give 4 of them a description, and then close the pop up, only the images that got a description show, but with "broken" thumbnails EXACTLY like your screenshot... the other images aren't even there...

Truncated file table. Rebuilt. File permissions on assets and php /tmp folder to 777. Deleted all versions tables, rebuilt. None of these solutions (mentioned elsewhere in the forums) work...

What is going on with this beautiful module? On earlier versions I never had troubles with it...

Any tips on how to debug are also appreciated...


Community Member, 137 Posts

2 December 2010 at 2:27pm

Pasqualito you have to got to unclecheeses website and download the "VERY" latest version of the imagegallery off his SVN

As there was a bit of code that was wrong with 2.4.3 I think he said.

As soon as I did that it fixed it up it all works well again!

See how you go


Community Member, 11 Posts

3 December 2010 at 3:29am

Edited: 03/12/2010 3:52am

Thanks tf22Raptor, will give that a try.

In case people have trouble downloading of SVN sources, I found that Forklift can connect really easy. Maybe every FTP client can do this?

** after updating: SO FAR, SO GOOD...

EDIT 2: Images only get saved to the album if you walk trough them one by one in the upload-pop up, after uploading. Adding a description is no longer needed, as long as you go through every image you uploaded.

Not 100% solved, then. But at least its workable...



Forum Moderator, 4102 Posts

3 December 2010 at 4:00am

For the record, the download section here on is supposed to be the latest trunk -- as is my website. Are you finding that it's out of date?


Community Member, 16 Posts

11 December 2010 at 5:52am

I am also experiencing the exact same issue. Have to walk through every image for them to show up in the gallery. Strange as they seem to be in the right folders and the table data looks OK. Missing something not sure what. I am using SS 2.4.3. Image Gallery r522 and DataObjectManager r515, using Uploadify.

Is there any other info I can give Uncle Cheese to help you resolve this?

Kind regards


Community Member, 11 Posts

15 December 2010 at 7:12am

Edited: 15/12/2010 7:21am

Well the problem still is not solved. I have a clients website that just won't accept any new images in freshly created albums anymore... updated EVERYTHING to the latest versions. Setting an album image seems to go fine but adding images to the album just is broken.

Here's what I get in the upload form now, and after saving - NO IMAGES

Second screenshot is after uploading images, clicking through the descriptions (although there's no thumbnails in the pop up)


Terry Apodaca

Community Member, 112 Posts

15 December 2010 at 8:36am


I have noticed that they are not always in sync. I've talked to a couple other module owners as well.

Go to Top