Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

MultiForm 0.3 shows blank page; 0.2 works all right

Go to End

3 Posts   1612 Views

Gerard Mengerink

Community Member, 3 Posts

21 November 2010 at 4:44am

Edited: 21/11/2010 4:46am

I followed the tutorial on MultiForm in The Complete Guide ... and got stuck on starting the MultiForm using the RegistrationPage. Foud out that if I left the "extends MultiForm" out in the RegistrationMultiForm class (so no inheritance), made my own constructor and put a debug in it, that debug showed up. If I reactivated the extends MultiForm I got that blank page again.

I replaced the 0.3 MultiForm with the 0.2 MultiForm found in the book code examples, did a dev/build?flush=all, and it worked right away.

There must be some error in the 0.3 module that either prevents it from installing completely a/o correctly, or installation of 0.3 was all right but there is some condition in the classes that cause this error.


Ryan M.

Community Member, 309 Posts

16 February 2011 at 7:34pm

Were you ever able to figure this out? I'm getting a blank page too.

The module info page on github says 2.4 is required, and I'm using 2.4.5. Maybe your problem was due to an older version of SS?


Community Member, 1 Post

9 April 2011 at 12:38am

Edited: 09/04/2011 12:40am


I have also tried to follow the code in silverstripe book, but now I receive [User Error] Uncaught InvalidArgumentException: $fields must be a valid FieldSet instance.

Please find Partner.php at