Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Member profiles module - Logout not working!


Go to End


3 Posts   1448 Views

Avatar
borriej

Community Member, 267 Posts

25 December 2010 at 8:57am

Hello,

Im using the member profiles module:
ajshort-silverstripe-memberprofiles-0.1.2-0-gd5bb1bf.zip

don't have a direct link to this module, downloaded it from some website.

All works well, but when im logged in as a front-end user .. and want to login as an admin..
I went to url.com/admin

You offcourse get the mssage:
I'm sorry, but you can't access that part of the CMS. If you want to log in as someone else, do so below

I click logout.. it will redirect to: url.com/Security/LoginForm

But i get an error!

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request POST /sapphire/main.php.

Reason: Error reading from remote server

Apache/2.2.9 (Debian) Server ... Port 80

When i go to: url.com/Security/logout
it will log-out.. but i want the SilverStripe generated log-out button to work.

How could i Fix this?

Avatar
borriej

Community Member, 267 Posts

29 December 2010 at 6:12am

solved.

reinstalled module

& added under allowed:
'loginform'

now it works.

Avatar
marc79

Community Member, 65 Posts

30 March 2011 at 6:28am

Edited: 30/03/2011 6:28am

Hi borriej,

Did you have to add the Logout button yourself? I have just installed the Member Profile mod and there isn't a log out button at all on the Edit Profile page.

Thanks

Marc