Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Error installing Subsites [solved]


Go to End


9 Posts   3812 Views

Avatar
zenmonkey

Community Member, 545 Posts

7 January 2011 at 3:29am

I'm getting the following error installing Subsites

Notice: DataObjectDecorator::extraDBFields() is deprecated. Please use extraStatics() instead. in /Applications/MAMP/htdocs/avelli/sapphire/core/model/DataObjectDecorator.php on line 60

Fatal error: Using $this when not in object context in /Applications/MAMP/htdocs/avelli/subsites/code/SiteTreeSubsites.php on line 32

I'm on 2.4.4

Any Ideas?

Avatar
ender

Community Member, 7 Posts

3 February 2011 at 7:23am

Edited: 03/02/2011 7:24am

I have the same problem.

Please advice

Avatar
kindleman.com.au

Community Member, 70 Posts

17 February 2011 at 4:42pm

Hi, Has anybody resolved this yet?

Ive just donwloaded Silverstripe to asses it for a multi site project. Ive downloaded 2.4.5 and installed no problem, downloaded the subsites module into the route and i got this error.

Bit of a show stopper which is a shame.

Thanks for any help,

Will

Avatar
honeybunny

Community Member, 79 Posts

18 February 2011 at 8:30am

I seem to remember this problem cropping up last year (may have been a different module) but I think the fix was to go into the php file and change the line that says extraDBFields() to extraStatics()

-------
Will, I tried the subsite module last year and while it did what it said it would do, it didn't really do what I needed. (I didn't need the sites to share an admin interface, and I wanted some of them on their own database.) I found that using symlinks to run multiple sites with one installation of SS was the best solution for me. I now have six or seven sites running under one installation. Some have their own database, others share one. I haven't had any problems, even when upgrading SS or modules. Just my 2 cents...

HB

Avatar
zenmonkey

Community Member, 545 Posts

18 February 2011 at 8:45am

Yeah I think thats what I did in the end.

Cheers

Avatar
kindleman.com.au

Community Member, 70 Posts

18 February 2011 at 9:34am

Hi Thanks for updating this,

I don't think thats sufficient to solve the problem. The fatal error is from using $this outside obect scope. I tried replacing the old function name throughout the module but it didn't fix the fatal error.

Any other sugestions / patches to get the latest version working with this module?

We definetly want to run off the same DB. Our requirement is for a central login to be able to provide content that filters down to the subsites - some news, pages etc . And for each subsite to be able to have their own content.

Thanks

Will

Avatar
DL

Community Member, 13 Posts

10 March 2011 at 12:48pm

I had the same problems described above with SS2.4.5 and the subsites module. Here's what I did to solve the problem:
1st) Download the latest revision of the module. At the time of writing, for me, this was:
Build Date: 2011-03-02
Download: silverstripe-subsites-master-HEAD.tar.gz
2nd) Create a folder called subsites and unpack the contents of the file above into it.
3rd) I ran a /dev/build/?flush=1 , but I got a load of errors, including some of those reported above. I came across several posts including one where someone was advising that we should comment-out certain lines within the subsites/_config.php, but that really didn't seem right to me. So what I did was to simply remove the contents of the subsites/_config.php file and place it into the main _config.php file in the mysites folder. Then I ran the dev/build/?flush=1 and that fixed it for me!

Hope this helps someone.

Avatar
Antti

Community Member, 6 Posts

13 April 2011 at 7:55pm

Intresting that this is marked as solved. I have tryed D-L's solutions... dosnt work for me. tryed renaming function but still get $this error...

I love silverstripe but when it comes to modules they always seem to have some issues. I know this is done for version 2.2 or something but my brain hurts if i must learn every version of SS if i wanna use different modules :)

D-L where in _config.php did you those susites/_config.php lines?

Go to Top