Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

CMS Workflow issues

Go to End

4 Posts   1253 Views


Community Member, 2 Posts

17 March 2011 at 1:05pm


Have looked all through the forums for help with the CMS Workflow issues I'm having, but so far none have applied/fixed my problems. Quite a few just say "I reinstalled and everything works now", unfortunately I've tried that a few times now with no luck.

Running SilverStripe 2.4.5 and CMS Workflow v1.0 rc4. No specific roles set up as yet, this issue is occurring when logged in as administrator.

When editing or creating a page, I can save the content but as soon as I try to publish it I see "Error saving content" and the page hangs. Otherwise if I just save and then try to approve it later, I see "Server error".

I've tried installing SS in two different environments with the same results.

I'm really keen to use SS, and the CMS Workflow is exactly what I need - but it's getting incredibly frustrating.

Bearing in mind that I'm no expert at all this stuff, please let me know what details I need to provide for you to help me out. All assistance is greatly appreciated.



Community Member, 2 Posts

18 March 2011 at 4:33pm

Edited: 18/03/2011 4:34pm

I've managed to find a workaround/fix for this issue, although I'm at a loss as to why these lines weren't included. I was getting 403 Forbidden errors when I tried to approve or publish, so added the following actions to LeftAndMainCMSWorkflow.php at line 5 (public static $allowed_actions):


Everything seems to be working now - hopefully this will help any others who strike the same problem.


Community Member, 18 Posts

24 March 2011 at 12:38pm

Edited: 24/03/2011 12:39pm

I have been "TRYING" to use this module (as I really need it in a project).

RC4 breaks on installation:

public static function addToGroupByName($member, $groupcode) {
185 		user_error('Group::addToGroupByName is deprecated. Please use $member->addToGroupByCode($groupcode)', E_USER_NOTICE);
187 		return $member->addToGroupByCode($groupcode);
188 	}

I edited the php and replaced the deprecated function.
But then the html does not run on Firefox, it even breaks the main site:

XML Parsing Error: not well-formed
Location: http://localhost/AutoImmo/
Line Number 1091, Column 433:	<div id="FutureStateDate[date]" class="field date  nolabel"><div class="middleColumn"><input type="text" class="text nolabel" id="FutureStateDate-date" name="FutureStateDate[date]" value="" /></div></div><div id="FutureStateDate[time]" class="field time  nolabel"><div class="middleColumn"><input type="text" class="text nolabel" id="FutureStateDate-time" name="FutureStateDate[time]" value="" /></div></div><div class="clear"><!-- --></div>

I tried the latest revision and still the same problem.

Edit and I am never able to publish I always get Error in Publishing. I can just save!.


Community Member, 1 Post

20 June 2011 at 9:46pm

Thanks Jsaade:


that really sorted me out.