Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

CMS Workflow problems - Can't publish any pages

Go to End

6 Posts   1278 Views


Community Member, 8 Posts

13 June 2011 at 3:59pm

Hi there,

I'm new to SilverStripe and I'm considering using it for my next big web project. I've set up a development site, tested it out, and overall I'm very impressed, but for the life of me I can't get the CMS Workflow module to work.

I've tried uninstalling and reinstalling the module, and the whole site, several times, and I've tried setting it up on different stacks (XAMPP and WAMP) and on different OSs (Windows XP, Windows 7), but each time I run into the same problems with this module.

Firstly, I get an error message during installation about a reference to "addToGroupByName" in "/code/WorkflowSystemMember.php". Through trial and error I worked out that I can solve that problem by changing the line in WorkflowSystemMember.php from:

Group::addToGroupByName($su, 'administrators');



Then, however, once the module has been installed, I can no longer publish any pages.

For example, I'll make a change to a page and click "Request Publication" - all well and good - but then, when I try to action the request, I get a red "Server Error" message and no further explanation. This message appears no matter which action button I click ("Approve", "Request edit", "Deny", "Cancel" or "Comment").

If I try to bypass the workflow altogether and click "Save and Publish" on a page, I get a red "Error Saving Content" message, and the animated loading image on the "Publishing..." button continues to spin and spin.

Basically, once the module is installed, I can no longer publish any pages, regardless of whether I try to go through the workflow, or just click "Save and Publish".

Once I've removed the module, I can publish pages again.

Can anyone help me out here?

As I mentioned above, I'm very impressed with SilverStripe and leaning towards using it for my next big site, but my inability to get this module working is holding me back.

Thanks in advance for your help.


Forum Moderator, 5523 Posts

13 June 2011 at 5:27pm

get a red "Server Error" message

If you use Firebug (for Firefox) then a detailed error log will be included as the response in your XHR request. The same information is also available in webkits inspector but it's a little harder to get to. In chrome under network -> XHR -> Click on the request -> Content which will include the same debug backtrace (as long as the site is in devmode).


Community Member, 8 Posts

14 June 2011 at 8:15am

Thanks for the fast response, and the handy tip about Firebug and Chrome.

The error message says:

403//Action "cms_approve" not allowed on controller (Class: CMSMain)

Does that mean anything to you?


Community Member, 8 Posts

20 June 2011 at 8:18am

Does anyone have any other thoughts regarding this?

I'm guessing what I'm experiencing isn't a common problem, because I can't find any information describing this particular problem.


Forum Moderator, 5523 Posts

20 June 2011 at 9:24am

Sounds like it's fixed. Do you still see the issue in the master release of cmsworkflow.


Community Member, 8 Posts

20 June 2011 at 2:22pm

Ah, so it is! Excellent.

Thanks - very impressed with the speedy turn-around. :)