Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Lucene - illegal character!


Go to End


2 Posts   1195 Views

Avatar
borriej

Community Member, 267 Posts

22 June 2011 at 12:22am

Edited: 22/06/2011 12:24am

Ok ive installed lucene
got the version from this website - 0.33 - lucene-silverstripe-plugin-0.3.3.tar.gz

added this to config:

ZendSearchLuceneSearchable::enable();

Now i want to index the site:
clicked on the button: Rebuild Search Index (on the SiteConfig /admin openingspage)

opened firebug

and saw this error:

ERROR [Notice]: iconv() [<a href='function.iconv'>function.iconv</a>]: Detected an illegal character in input string IN POST /sapphire/main.php?url=/admin/RootForm& Line 62

on line 62 it says:

 $this->_input = iconv($this->_encoding, 'ASCII//TRANSLIT', $this->_input);

also tried:

$this->_input = iconv('UTF-8', 'ISO-8859-1//TRANSLIT', $this->_input); 

But the error keeps showing up, how do i index my site ?

Thx in advance!

Avatar
borriej

Community Member, 267 Posts

28 June 2011 at 1:38am

got the latest version from github and everything was ok..