Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Compass module help

Go to End

4 Posts   2620 Views

Matty Balaam

Community Member, 74 Posts

2 December 2011 at 8:42am


I'm running Silverstripe on MAMP on Lion, but I guess I'm doing something wrong.

I managed to run sapphire/sake dev/compass/convert --theme=foo, which worked, but I want to use SCSS rather than SASS.

I used tool to convert my css to scss, placed them into the sass/ folder and put:

preferred_syntax= :scss

into the config.rb file.

However I get the following message when I go to dev/compass/rebuild:
[User Error] Compass Error:Nothing to compile. If you're trying to start a new project, you have left off the directory argument.Run "compass -h" to get help.

Additionally if I go to: dev/compass I get another error:
[User Error] Uncaught Exception: Object->__call(): the method 'index' does not exist on 'Compass'

These errors happen both through the browser and through the terminal.

I'm sure it's something really simple! But if someone could help me out of my misery.

Matty Balaam

Community Member, 74 Posts

7 December 2011 at 12:13am

Just bumping in case anyone has any ideas?

I ended up using compass through the terminal watching a folder, but it would be more convenient if the module worked.


Forum Moderator, 5523 Posts

13 December 2011 at 9:17pm

What is the contents of your config.rb?

Also make sure Compass::$syntax = scss for your use case.

Matty Balaam

Community Member, 74 Posts

16 December 2011 at 11:54am

Hi, thanks, it's now compiling. But I still get the error when I go to dev/compass.

Here's the config.rb

require 'susy'

http_path = "/"
css_dir = "css"
sass_dir = "scss"
images_dir = "images"
javascripts_dir = "javascripts"

output_style = :expanded