Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Compass module - using alpha/beta


Go to End


4 Posts   949 Views

Avatar
Matty Balaam

Community Member, 74 Posts

24 January 2012 at 10:43pm

I'm trying to use a compass add-on for css3 animations: https://github.com/ericam/compass-animation I get the following error if I try to use it:

Unable to activate animation-0.1.alpha.0, because compass-0.11.7 conflicts with compass (>= 0.12.alpha.0)

Is there a way to force the Compass module onto the latest release? I see in Compass.php there is $sass_version which I've tried to set to 'latest' but it then gives me the following error:

[User Error] Compass Error:/Library/Ruby/Site/1.8/rubygems/requirement.rb:81:in `parse': Illformed requirement [""] (ArgumentError) from /Library/Ruby/Site/1.8/rubygems/requirement.rb:106:in `initialize' from /Library/Ruby/Site/1.8/rubygems/requirement.rb:106:in `map!' from /Library/Ruby/Site/1.8/rubygems/requirement.rb:106:in `initialize' from /Library/Ruby/Site/1.8/rubygems/requirement.rb:44:in `new' from /Library/Ruby/Site/1.8/rubygems/requirement.rb:44:in `create' from /Library/Ruby/Site/1.8/rubygems/dependency.rb:50:in `initialize' from /Library/Ruby/Site/1.8/rubygems.rb:303:in `new' from /Library/Ruby/Site/1.8/rubygems.rb:303:in `bin_path' from -e:6

Thanks.

Avatar
Willr

Forum Moderator, 5523 Posts

8 February 2012 at 9:54pm

because compass-0.11.7 conflicts with compass (>= 0.12.alpha.0)

Looks like you should uninstall 0.11.7 first.

Avatar
Matty Balaam

Community Member, 74 Posts

9 February 2012 at 12:18am

Edited: 09/02/2012 12:31am

I'm a bit confused, I was under the impression that the Compass module took care of selecting the latest gems?

Edit: Took another look and managed to get it woking by changes the code in Compass.php on line 39 to

'yard' => '', 'maruku' => '', 'haml' => '~> 3.1', 'compass' => '>= 0.12.alpha.0', 'compass-colors' => ''

I guess there must be a way of overriding this without hacking the code?

Avatar
Matty Balaam

Community Member, 74 Posts

9 February 2012 at 1:08am

Actually it didn't work, it now won't compile any code. If I delete the CSS files already there they are not remade.