Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Uploadify problem when I want get images that are already uploaded.


Go to End


4 Posts   896 Views

Avatar
Josua

Community Member, 87 Posts

9 February 2012 at 9:18am

Hello!

I have installed DataObjectManager and Uploadify.

I'm trying to use images that are already uploaded, but does not work correctly.
For example, if I have images in assets/Uploads/intro and I want use 2 of them:
1) Select 'Choose editing' tab
2) Combobox: - Select a folder - ==> assets/Uploads/intro
3) Check the 2 images I want (bar1.jpg, bar2.jpg).
4) Click 'Import' button.
5) Click 'Continue' button.
6) Editing file 1 of 2 (assets/Uploads/bar1.jpg)
7) Editing file 2 of 2 (assets/Uploads/bar2.jpg)
8) Click 'Finish' button.

The images are copied from assets/Uploads/intro to assets/Uploads

Why?

I just want to use these 2 images, I don't want to copy them to the assets/Uploads folder.

Is it right what Uploadify are doing?

Thanks,

Regards,
Jose A.

Avatar
benni91

Community Member, 72 Posts

9 February 2012 at 12:01pm

Edited: 09/02/2012 12:02pm

Hi,

i think all of your images are dublicated to assets/uploads.
just add $Manager->copyOnImport = false; to your PageType. This should solve your problem.

Benni

Avatar
Josua

Community Member, 87 Posts

9 February 2012 at 11:07pm

Hi Benni,

Thank you.
It works perfectly. :)

Regards,
Jose A.

Avatar
benni91

Community Member, 72 Posts

10 February 2012 at 2:16am

No Problem,

i had a similar problem which drove me crazy :D