Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Flickr installation issue


Go to End


2 Posts   569 Views

Avatar
Simpmarv

Community Member, 1 Post

13 March 2012 at 8:14am

I followed the directions for installing the Flickr module but I am not getting a Flickr page type in the CMS.

I'm not sure if I put the code in the correct loction.

/home/stithe/public_html/mysite/_config.php

<?php

global $project;
$project = 'mysite';

global $databaseConfig;
$databaseConfig = array(
"type" => 'MySQLDatabase',
"server" => 'localhost',
"username" => 'stithe_stri801',
"password" => 'Pe8lro',
"database" => 'stithe_stri801',
"path" => '',
);

MySQLDatabase::set_connection_charset('utf8');

// This line set's the current theme. More themes can be
// downloaded from http://www.silverstripe.org/themes/
SSViewer::set_theme('natureweb4');

// Set the site locale
i18n::set_locale('en_US');

// enable nested URLs for this site (e.g. page/sub-page/)
SiteTree::enable_nested_urls (FlickrService::setAPIKey('30ea1f2c5b7ce3fcedabe9d65d376'));

Thanks for your help,
Dave

Avatar
BrixtonBoy

Community Member, 7 Posts

18 March 2012 at 8:04pm

I think your _config.php is in the right place, but its content is not quite right.

Instead of ...
// enable nested URLs for this site (e.g. page/sub-page/)
SiteTree::enable_nested_urls (FlickrService::setAPIKey('30ea1f2c5b7ce3fcedabe9d65d376'));

try this ...
// enable nested URLs for this site (e.g. page/sub-page/)
SiteTree::enable_nested_urls();

// set api for flickr
FlickrService::setAPIKey('30ea1f2c5b7ce3fcedabe9d65d376');