Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Dashboard Module for SilverStripe 3


Go to End


12 Posts   3492 Views

Avatar
UncleCheese

Forum Moderator, 4102 Posts

4 October 2012 at 4:21am

I've created a highly extensible dashboard module for SS3. Keen to get everyone's feedback.

Blog post/Screencasts: http://www.leftandmain.com/silverstripe-screencasts/2012/10/03/dashboard-module-for-silverstripe-3/

Demo: http://dashboard.unclecheeseproductions.com/admin

Github: http://github.com/unclecheese/silverstripe-dashboard

-------------
SilverStripe tips, tutorials, screencasts, and more
http://www.leftandmain.com

Avatar
omyzach

Community Member, 3 Posts

5 October 2012 at 3:14am

Awesome module.

I'm loving it!

Avatar
dacar

Community Member, 173 Posts

19 October 2012 at 9:27am

Edited: 19/10/2012 9:27am

Hi, since yesterday i am testing SS3.0.3. After some installing problems i am now testing some modules. With the dashboard module i have some problems. Installation worked fine. I can add all dashboards but i can not delete or save. Here is the error message:

[18-Oct-2012 21:39:25] Error at framework/core/Core.php line 372: singleton() Called without a class ([..]/admin/dashboard/panel/4/gridsforpage?pageid=7)

Can anybody help?

Greetings, Carsten.

Avatar
UncleCheese

Forum Moderator, 4102 Posts

19 October 2012 at 9:32am

Not enough context. I'd need to see the whole error output.

---------------
Silverstripe tips, tutorials, screencasts, and more. http://www.leftandmain.com

Avatar
dacar

Community Member, 173 Posts

19 October 2012 at 9:51am

Hi Uncle Cheese,

that is a big problem at the moment. I am working on a virtual host machine. Most of my settings in _config.php does not work anymore. Even

SS_Log::add_writer(new SS_LogFileWriter(Director::baseFolder() . '/error_log.txt'), SS_Log::ERR);
SS_Log::add_writer(new SS_LogFileWriter(Director::baseFolder() . '/error_log.txt'), SS_Log::NOTICE)
SS_Log::add_writer(new SS_LogFileWriter(Director::baseFolder() . '/error_log.txt'), SS_Log::WARN);

does not write any logfiles. Can you provide a "master" _config.php?

Also everything is very slow. I have about more then 50 silverstripe installations at www.bytecamp.net. There has never been any problem with SS2.x.

Greetings, Carsten.

Avatar
dacar

Community Member, 173 Posts

20 October 2012 at 2:03am

hmm, i think it has something todo withe the translatable module:

Trace
=====
user_error(singleton() Called without a class,256)
Core.php:372

singleton()
DataObject.php:2768

DataObject::get_one(,"ID" = 1,1)
DataObject.php:2879

DataObject::get_by_id(,1)
TranslatableCMSMainExtension.php:23

TranslatableCMSMainExtension->init(,,,,,,)
Object.php:898

Object->extend(init,)
LeftAndMain.php:345

Greetings, Carsten.

Avatar
dacar

Community Member, 173 Posts

20 October 2012 at 2:19am

... i have just uploaded an update of the translatable module from Git. Now everything works fine!

Greetings, Carsten.

Avatar
UncleCheese

Forum Moderator, 4102 Posts

20 October 2012 at 2:33am

Great! Thanks for documenting!

---------------
Silverstripe tips, tutorials, screencasts, and more. http://www.leftandmain.com

Go to Top