Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

googlesitemaps for SS 3.0


Go to End


3 Posts   912 Views

Avatar
dacar

Community Member, 173 Posts

6 November 2012 at 11:38am

Hi, i am just testing the googlesitemaps module for SS 3.2. There is a problem to get a valid .xml because of the $Priority. in my sitemap.xml $Priority is not correctely formated as a float: <priority>0,9</priority>.

In my _config.php i have set: setlocale (LC_ALL, 'de_DE@euro', 'de_DE.UTF-8', 'de_DE', 'de', 'ge');

Is there a way to set setlocale(LC_NUMERIC, 'en_US') just for the sitemap.xml?

Also ther is an error in GoogleSitemap.ss instead of <% if $ChangeFreq %><changefreq>$ChangeFreq</changefreq><% end_if %> it should be: <% if $getChangeFrequency %><changefreq>$getChangeFrequency</changefreq><% end_if %>.

Hope, that someone can help.

Greetings, Carsten.

Avatar
Juanitou

Community Member, 323 Posts

7 November 2012 at 1:04am

Hi Carsten.

May I suggest you to open a ticket in GitHub?
https://github.com/silverstripe-labs/silverstripe-googlesitemaps/issues

I think it’s the better way to get these issues resolved.

Best regards,
Juan

Avatar
dacar

Community Member, 173 Posts

7 November 2012 at 4:16am