Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Sublime Text 2 package with syntax highlighting (link)


Go to End


10 Posts   4779 Views

Avatar
benjamin-smith

Community Member, 17 Posts

22 August 2013 at 8:48am

Thanks for the feedback Bob! I have created a GitHub issue to track this, I'll post back here as well when complete:

https://github.com/benjamin-smith/sublime-text-silverstripe/issues/8

Avatar
acoggins

Community Member, 19 Posts

5 March 2015 at 8:50pm

Edited: 06/03/2015 12:38am

In case anyone is experiencing problems with this not working, we've just discovered a possible solution.

We set up the package as per instructions but Sublime still kept opening the ss file as a Lisp type. So, we went into Preferences => Browse Packages => Lisp and opened (using Sublime) the 'Lisp.sublime-setting' file, where we found this line: "extensions": ["lisp", "scm", "ss"]

We deleted the "ss" reference here and then our ss files open correctly as SilverStripe type.

By the way, THANKS Benjamin.

Go to Top