Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

userforms installation not succesful

Go to End

14 Posts   2749 Views


Community Member, 25 Posts

26 April 2009 at 8:36am

Edited: 26/04/2009 8:43am

(Using SS 2.3.1)

I extracted the latest userforms download into my sites root folder.

Then I did:

and then:

After this, in the Site Content, when I try to create a new Page, I don't see the 'a contact form' page type.

To verify, I checked the folder structure where I extracted the userforms zip file. It is :
and all the permissions are rwxrwxrwxr for all the files and folders.

Any thing / step that I missed?


Forum Moderator, 922 Posts

26 April 2009 at 11:00pm

I think you've put it in the wrong place.

The "userforms" directory needs to live as a sibling of the sapphire, cms, jsparty and mysite folders.

Once it's there, dev/build (or db/build if you're running 2.2) should then pick up the module and build the database accordingly.

Good luck!



Community Member, 25 Posts

27 April 2009 at 7:55am

1. I tried what you said but got errors about duplicate classes when doing the build. So I deleted from cms and mysite folders, and tried again - it worked.

2. This install procedure should be documented somewhere, it isn't currently.



Community Member, 25 Posts

27 April 2009 at 8:28am

correction: I deleted from mysite and sapphire folders.


Community Member, 25 Posts

27 April 2009 at 8:30am

still not working....


Community Member, 25 Posts

27 April 2009 at 8:34am

see build errors attached. let me know again the correct install procedure.

Attached Files

Community Member, 25 Posts

27 April 2009 at 8:37am

im very dissapointed that it is so difficult to install and that the proper way is not documented anywhere.


Community Member, 607 Posts

27 April 2009 at 11:41am

Edited: 27/04/2009 11:44am

You know, I find myself agreeing with you in part on this.

Even the most basic of docs, the download links, are totally messed up and unclear for this module, arguably the most important module for SS. (Who doesn't need a contact form?)

The official page for the module has a download link to the stable 1.0 archive. Under that is a link to the "latest unstable trunk", which as of now is r75112:

While the docs page, which everyone is prompted to check out straight off the bat has a link to there is a main heading at the top that says "Download". The link here downloads a different "trunk" which is r75129. Not a single mention of the stable release.

On top of this, if you go to, the REAL trunk version appears to be r75143.

There is some serious ambiguity here and lack of direction guys - especially for new Silverstripers. And I feel it's only simple things like updating links in the Docs. Maybe download links in the docs should just be sent to the official module pages?


Go to Top