Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

New module - Simplify - customise the CMS interface

Go to End

46 Posts   11588 Views


Community Member, 43 Posts

20 October 2009 at 9:06am

Hi all,

Thanks for your patience, please find attached the latest version of Simplify (0.0.2). This has the following features:

- Simplify now has its own tab under each Security/Group, with easy to use checkboxes - no need to use the Permissions tab, scroll through drop downs etc.

- Powerful Fields checkbox tree - Hide any page, tab or field from a group just by clicking.

- Several new permissions added:
- Hide the Draft Site link
- Hide the Published Site link
- Hide the version and link in footer
- Hide the Profile link
- Hide pages this group cannot view or edit (>> very useful, removes entries in the tree that the uses cannot view or edit (set in Access)

- Permissions can now be applied to Admin groups (including the default group)

Remember this is still in development, any issues or problems just let me know.


Attached Files

Community Member, 15 Posts

20 October 2009 at 6:39pm


Very nice, Thanks for your hard works.



Community Member, 30 Posts

21 October 2009 at 3:24am

Looks great.
I've come across a problem however.

I install simplify, and create some rules (the demo set for example) for a particular use group.
It works as expected if I then log in as a user in that user group, but am then unable to log in as the main admin again.

I'm probably doing something inherently wrong. Has anyone else had this?



Community Member, 43 Posts

21 October 2009 at 8:48pm

Edited: 21/10/2009 9:15pm

Hi kevino,

What do you mean by can't log in? What error are you getting? Also, letting me know what version of Silverstripe and what modules you have installed woud help.

Oh, and what options you're picking in Simplify too :)

One last thing - try restarting the browser and clearing the cache between login attempts for different group users.



Community Member, 30 Posts

21 October 2009 at 11:52pm

Hi Daniel,

When I come to log back in as the original administrator, after changing settings for another user group, I get the error:

Website Error
There has been an error

The website server has not been able to respond to your request.

Contact an administrator

The error ^^ is in the same format as a db build error (if that makes sense).

I'm using SS 2.3.3
I've got the ecommerce, dataobject manager, and swfupload modules installed too.

I've used the demo set of settings, and also just the hide logo setting in Simplify. It works for the group I'm "simplifying", but when I log out and then log in again as the original Admin, I get the error.

If I delete the Simplify module via FTP, and rebuild, I can log in fine again.



Community Member, 54 Posts

22 October 2009 at 12:20am

Hi Froog, i think there is a problem with the module, when I install it in a fresh site this error appears:

[User Error] Couldn't run query: SELECT `Permission`.*, `SimplifyPermission`.*, `Permission`.ID, if(`Permission`.ClassName,`Permission`.ClassName,'Permission') AS RecordClassName FROM `Permission` LEFT JOIN `SimplifyPermission` ON `SimplifyPermission`.ID = `Permission`.ID WHERE (`Code` = 'ADMIN') ORDER BY ID LIMIT 1 Column 'ID' in order clause is ambiguous

after dev/build

other test i have made:
deleted the module, created a new user group and then added the module: this worked, i was able to enter the admin, but, then I added some permissions using simplify and logout. after that the same error appeared


Community Member, 43 Posts

22 October 2009 at 12:37pm

kevino - add the following line to your mysite/_config .php, it will let you see a more detailed error report which you can post.


dospuntocero - Are you using Silverstripe 2.3.3? - I just did a fresh install and added Simplify and it works fine. Changing the default admin password may also help fix the issue you're seeing.


Community Member, 54 Posts

22 October 2009 at 4:04pm

froog, im using 2.3.3 from svn, i have deleted the database and the same error appears :(