Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Getting Recaptcha to work in UserForms Module


Go to End


12 Posts   7779 Views

Avatar
Media Contour

Community Member, 33 Posts

25 November 2009 at 11:20am

I followed the instruction to setup the reCaptcha and I still get the following error.

Fatal error: Class 'RecaptchaProtector' not found in /var/www/stage/fit/spamprotection/code/EditableSpamProtectionField.php on line 31

Avatar
Sunnybex

Community Member, 39 Posts

5 January 2010 at 6:37am

Hi there,

I am getting the same error message as victuoso

Any suggestions?
Thanks in advance

Bex

Avatar
merrick_sd

Community Member, 99 Posts

18 February 2011 at 1:13am

I have installed
chillu-recaptcha-ecb4394

with silverstripe 2.4.5
Im using

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>

the page load etc and i see the recaptcha .etc but i see js error

js details
Uncaught TypeError: Cannot set property 'innerHTML' of null

in the readme it says

## Known issues:

ReCAPTCHA current does not work if the page doctype is XHTML. The API returns
Javascript which uses "document.write", which is not supported in XHTML.
A work-around is to always use the no-script version of the module (modify the
relevant lines in RecaptchaField.php), or to switch your webpage's doctype to
HTML 4. See: http://www.w3schools.com/tags/tag_DOCTYPE.asp

Question:I want to stay with Xhtml strict
It says modify the
relevant lines in RecaptchaField.php, but which lines?

Avatar
spijker1056

Community Member, 8 Posts

12 July 2013 at 4:32pm

Edited: 12/07/2013 4:41pm

Hi and thanks for your suggestions to this point.

I have an ss3.0.5 install of Silverstripe on my localhost at this time.
I have installed the REcaptcha module and the spamprotector module.
I have also put the public and private keys and the SpamProtectorManager::set_spam_protector('RecaptchaProtector'); for spam protector.
I am also using the userforms module.

I have now got to the point where everything runs fine and I can add the spam protector field to the form but it does not display on the form.

I also followed the tip to log out of my admin but still no reccaptcha showing up.

And yes I also did the obligatory flush=all .,.. ;-)

Can you suggest what I might be doing wrong or may have omitted.

Many Thanks

Rob

Go to Top