Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Error during Installation

Go to End

5 Posts   3081 Views


1 Post

1 November 2007 at 3:30am

Hello everybody.
I am installing Silverstripe 2.1
During the installation i am getting the following error:

If you receive a fatal error, refresh this page to continue the installation
Creating 'mysite/_config.php'...
Creating '.htaccess' file...
Warning: Installer::require_once(core/control/Director.php) [function.Installer-require-once]: failed to open stream: No such file or directory in D:\Webserver\\www\silver\install.php on line 620
Fatal error: Installer::require_once() [function.require]: Failed opening required 'core/control/Director.php' (include_path='.;C:\php5\pear') in D:\Webserver\\www\silver\install.php on line 620

Can anybody advice me where is the problem.


1 Post

11 November 2007 at 7:51pm

I am getting hang during install. I had this running on an adjacent domain so I know SS works on my server.
On the other domain I installed 2.1.0 and then updated to 2.1.1 but on the NEW domain I just installed 2.1.1 or am attempting to at any rate...

Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation
# Creating 'mysite/_config.php'...
# Creating '.htaccess' file...
# Building database schema...


Then the install hangs here.


9 Posts

13 November 2007 at 1:34pm

Edited: 13/11/2007 1:50pm

i've tried about everything and installed 20 times (i kid you not). mine keeps hanging at the exact same place over and over again. except once, when it told me my memory limit wasn't high enough (at the time it was set to the recommended 32Mb, now it is at 34Mb, but no difference, it still hangs).

just so you know, you're not alone :(


Community Member, 2 Posts

21 November 2007 at 11:24am

Edited: 22/11/2007 2:04am

Same here... after(?) building the db schema the installation hangs.... Any ideas?


The v2.2.0rc-1 worked fine... - but just once... :(

Is there any type of error reporting or log which can be examined? Or what about a manual installation?


I tracked down the problem to the compileManifest Funktion so far.

static function compileManifest() {
                // Config manifest
                $baseDir = dirname($_SERVER['SCRIPT_FILENAME']) . "/..";
                $baseDir = ereg_replace("/[^/]+/\\.\\.", "", $baseDir);
                // locate and include the exclude files
                $topLevel = scandir($baseDir);
                foreach($topLevel as $file) {
###############here it crashes##############
$fullPath = $baseDir . '/' . $file;
[/code ]


53 Posts

23 November 2007 at 1:52am

I've had problem due to open base directory restriction that could be causing an error.

the scandir returns . and ../ and so when the is_dir is called the open base directory restriction applies as you are attempting to look outside of the allowed directory.

I've added if(substr($file,0,1) == '.') continue; in the foreach to prevent this.

Its also required further down please see my post on this.

This may or may not help but thought I would share to possibly help.