Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Support for multilingual content


Go to End


12 Posts   7091 Views

Avatar
konfjuzd

16 Posts

14 November 2007 at 10:37pm

How this works? any samples / tuts / docs?

Avatar
Fuzz10

Community Member, 791 Posts

15 November 2007 at 1:24am

Avatar
konfjuzd

16 Posts

15 November 2007 at 10:57am

hmm, nice but I fail on first line:

Fatal error: Class 'phpi18n' not found in /home/XXXX/XXXXX/_config.php on line 1
I put i18n::enable(); on top of config file.

Avatar
Sigurd

Forum Moderator, 628 Posts

15 November 2007 at 2:57pm

It requires SilverStripe 2.2+

Avatar
Andante

Community Member, 231 Posts

15 November 2007 at 3:53pm

also it sounds like you have

<?phpi18n::enable()

instead of

<?php
i18n::enable()

Avatar
konfjuzd

16 Posts

15 November 2007 at 10:40pm

Edited: 15/11/2007 10:41pm

ok, it was <?phpi18n............

but now i have:

ERROR:
Error

The website server has not been able to respond to your request.

(and /db/build brings blank screen)

Avatar
Henk Poley

30 Posts

30 November 2007 at 12:08am

Could somebody take a look at ticket #1928? Enabling i18n seemed to work fine. But I can't create translated pages.

Avatar
Sigurd

Forum Moderator, 628 Posts

5 December 2007 at 10:17am

konfjuzd; turn devmode on to see your error.

Go to Top