Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Problem with adding multiple records through popup (ComplexTableField)


Go to End


5 Posts   1510 Views

Avatar
Fuzz10

Community Member, 791 Posts

27 November 2007 at 12:45am

Edited: 27/11/2007 2:55am

When adding multiple records at once through a complextablefield with popup the list does not refresh automatically.

See attached screenshots.

In screen 3 I already pressed the save button to add the record. The list does not refresh automatically.

In screen 4 I refreshed the page by hand.

TRAC# 1902
Is it enough to add the bug to TRAC or should I also mention it here ?

Avatar
Fuzz10

Community Member, 791 Posts

27 November 2007 at 12:46am

Screenshots

Avatar
Ingo

Forum Moderator, 801 Posts

27 November 2007 at 9:18am

this is a problem that keeps haunting is (weird combination of javascript-scopes and self-closing iframes) - thanks for your detailed report. its penciled in for the 2.2.1 release

Avatar
Fuzz10

Community Member, 791 Posts

27 November 2007 at 9:25am

Yep. Ajax is cool , but it has it's (debugging) downsides .. ;-)

I was trying to fix this myself , but could not figure out where the call was made. ;-)

BTW. Is it enough to put a new bug in TRAC or should I also make a note here in the forum ?

Avatar
Ingo

Forum Moderator, 801 Posts

27 November 2007 at 9:28am

oops, already created one and forgot to attach it here:
http://open.silverstripe.com/ticket/1902