Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Manifest error 133

Go to End

8 Posts   4292 Views


11 Posts

30 November 2007 at 3:24am


I have the following error when I go to my site. It is very problematic as the site is currently down after being up and operating fine for a few weeks. Any advice would be very welcome...

Warning: fopen(/tmp/silverstripe-cache/manifest_home_kt_public_html_site2_sapphire_main.php) [function.fopen]: failed to open stream: Permission denied in /home/kt/public_html/site2/sapphire/core/ManifestBuilder.php on line 133
Cannot write manifest file! Check permissions of /tmp/silverstripe-cache/manifest_home_kt_public_html_site2_sapphire_main.php

Many thanks,


11 Posts

30 November 2007 at 7:00am

I decided to upgrade the version of SilverStripe I'm running (replacing the cms, sapphire, jsparty and auth_openid folders), thinking that by upgrading I might resolve the problems.

Unfortunately the following error message comes up:

GET /images/I/5198BQYFP2L._PIsitb-dp-500-arrow,TopRight,45,-64_OU02_SS75_.jpg HTTP/1.1 Host: User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20071115 Firefox/ Accept: image/png,*/*;q=0.5 Accept-Language: en-us Accept-Encoding: gzip,deflate Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7 Keep-Alive: 300 Connection: keep-alive Referer:
Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 4864 bytes) in /home/bluesky/public_html/stopunumii/sapphire/core/Email.php on line 357

This is very odd as there is a link to a book on that I was thinking about buying last night (I wasn't looking at it while working on this problem today. It's as if some info from the history folder somehow got on the site!?!

I'm updated the saphire/main/config file to have the "ini_set(”memory_limit”,”32M”);" in the top line... I'e even changed up to as much as 85M just in case. No luck.

I've love if anyone has any advice...



11 Posts

30 November 2007 at 7:29am

Hi - I realised that the solution I pulled off the forums was incorrect because someone used " rather than ' - in the line that you change the memory to.

To help others with the same issue - to change the memory limit, use the following:

ini_set('memory_limit', '32M');



121 Posts

30 November 2007 at 7:30am

Did you try deleting your /tmp/silverstripe-cache folder when you hit the first problem?

Have you called /db/build?flush=1 since you upgraded?


11 Posts

30 November 2007 at 8:47am

Well, after changing the memory limit the site was working ok for a bit (except that I couldn't log in as my details weren't recognized!?! Another bug!!!). Now the site went down again...

This is the message (below) that I get now:

Warning: fopen(/tmp/silverstripe-cache-home-kt-public_html-site2/manifest_home_bt_public_html_stopunumii_sapphire_main.php) [function.fopen]: failed to open stream: Permission denied in /home/kt/public_html/site2/sapphire/core/ManifestBuilder.php on line 188
Cannot write manifest file! Check permissions of /tmp/silverstripe-cache-home-kt-public_html-site 2/manifest_home_kt_public_html_site2_sapphire_main.php

I'd like to know if any one has ideas on how to fix this - the site is offline and it is causing major problems.

Why does SilverStripe flip-out after working for for a while?

Many thanks,


Community Member, 21 Posts

30 November 2007 at 1:31pm

Edited: 30/11/2007 1:31pm


Like the error says, the web user doesn't have permission to write in that folder.

It isn't an SS bug, it's the filesystem in your hosted server that doesn't let you write in that directory, if it did previously, something changed, better ask the company running the server about it.

To stop worrying about silverstripe writing cache in folders where it will most likely do not have write permission, the best thing to do is to create a directory called silverstripe-cache in you silverstripe folder, make sure you give permissions on that folder to write files in it and silverstripe uses that folder instead.

Best regards,


Community Member, 12 Posts

17 October 2008 at 12:27am


I had the same problem. The site just randomly packed up and gave same 'Cannot write manifest file!' error. I created the folder silverstripe-cache in the root of the installation and set the permissions and it started working again.

Thanks for the help!

Big Al

Community Member, 6 Posts

4 December 2008 at 4:50pm

I was as well. It is one of a growing collection of changes to make when using 1and1.

This worked for me as well. Thank you.