Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Search in multilingual site


Go to End


4 Posts   2822 Views

Avatar
superautomatic

Community Member, 53 Posts

30 November 2007 at 5:21am

Hi,

I'm testing out the functionality of the multilingual feature, and a lot of it works really fine. Recently I ran into a problem with the search functionality though (implemented as in tutorial 4). When language is set to default (english), search works great, but if I switch to another language and perform a search I get an error that says:

"Error
The website server has not been able to respond to your request."

Do I need to implement the search in another way to support multiple languages?

Avatar
sybalos

Community Member, 4 Posts

3 March 2008 at 7:51am

I got the same problem. Anyone have a solution ?

Avatar
dio5

Community Member, 501 Posts

3 March 2008 at 8:34am

I think this is a bug, and there's a 'quick' patch for this in trac:

http://open.silverstripe.com/ticket/2267

Avatar
sybalos

Community Member, 4 Posts

3 March 2008 at 10:32am

Ok thanks for your reply.
The patch work almost well. Now i have problem with the pagination. I have 8 articles and it deal with only 4 of them in the default language ('en'). The pagination work in the other 2 language of my site. Any idea ?