Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Why was Silverstripe 2.2 released as stable?

Go to End

12 Posts   5986 Views


Community Member, 24 Posts

1 December 2007 at 1:14pm


Basically, as outlined by one of the devs in another thread, this was done in order to have something to celebrate in a newsletter that was due to go out this week.

I would like to register my disappointment about this action.

The "stable" is still incredibly unstable. I have not been able to install it, either locally or on one of my VPS's.

I get a error basically saying there are two identical files, which there are, in different folders. One helpful gentlemen suggested to another user here that the way to go would be to delete one of the files (which was apparently deprecated). Why was a deprecated file left in the release? Why are there duplicate files everywhere?

I know I must sound incredibly rude and ungrateful for complaining about a free product, but I stress that I make no complaint about Silverstripe, but about your decision to label it as stable, without proper testing.

I would like to suggest scrapping this forum, getting a more robust one such as phpBB3, and setting up a quality and testing group, for which I would like to volunteer my services.

I appreciate all the work you have done, and thanks for letting me post this.



Community Member, 25 Posts

2 December 2007 at 1:32am

Hi Marikas,

where did you find the errors?
I did an install on both my local server and on a webhost with till 2.2 version and it worked instantly. Maybe not much help for you, but it might be good to know that others have succeded to install it.

Im really impressed. Found SilverStripe last night and it looks really great :-)


Community Member, 791 Posts

2 December 2007 at 3:54am

Edited: 02/12/2007 3:56am

Can't say I really agree with you Marikas.

Of course, there are some bugs left, but one cannot expect any piece of software this size to be totally bugfree. Especially when you take into account the fact that the community is just starting and is nowhere near mature yet (the core-team has to do most , if not all, of the work patching , improving & fixing SilverStripe).

For me , the upgrade process didn't go without some hickups either , but I don't feel one can jump to the conclusion that SS isn't tested thoroughly. There have been multiple release candidates and the devs gave the community plenty of time to test / review it. Having tested all the release candidates , I understand the decision to deem the current release "stable" (enough to get out there anyway).

Just give it some time, the community needs to mature , docs need to be extended, processes will form...

By the way , It is not my intention to start a flamewar here .. I understand where you're coming from. It's just that I'm having a totally opposite feeling about the process. 4 (!) public release candidates before a launch , short intervals between them , I call that a job very well done , especially for a young Open Source project.


Community Member, 24 Posts

3 December 2007 at 12:51am

Darn it... must just be me then :(

I agree Fuzz10, it's a relatively new script that has yet to fully mature and I am expecting too much from it. I'm probably just really dissappointed because I really like how its looking and would love to get stuck into it but can't for some weird reason.

I doubt it's a server config issue because the previous RC managed to install and I was at least able to view the site. Upon deleting the old files and db and installing a fresh copy of the stable, nothing works. (see

Anyway, my silly rant is over. I shall persevere! :)


Google Summer of Code Hacker, 76 Posts

3 December 2007 at 9:23am

Hi Marikas,

Don't get so frustrated :) Actually SilverStripe is relatively new project and still maturing. Also the developer and testing community around SS is small and still growing. Any Open Source project in its early stages must have gone through this. Anyway SS has a proper release plan and a vision where its heading, so we could expect it to be more stabilized in the releases to come.

Anyway have you tried to install SS 2.2 on a new folder ?, rather than upgrading the existing one.

>>I get a error basically saying there are two identical files, which there are, in different >>folders. One helpful gentlemen suggested to another user here that the way to go would >>be to delete one of the files (which was apparently deprecated). Why was a deprecated file >>left in the release? Why are there duplicate files everywhere?

SS 2.2 or modules released with it, doesn't contain any deprecated files. But if you are upgrading there is a chance of deprecated files remain in the system. In that case best way to go would be manually deleting the older files.


Forum Moderator, 628 Posts

4 December 2007 at 2:13pm

Edited: 04/12/2007 2:14pm


first off thanks for mentioning a desire to improve the QA of SilverStripe; we need more of you. Please join our silverstripe-announce mailing list to learn when beta versions come out which you can test, and add tickets to as you find issues. Be sure to label items as blockers against a certain milestone to communicate serverity. We'd also love for people to submit patches--you will appear in glory at !

While true that we wanted to mention the SilverStripe 2.2 release at the same time as the GHOP stuff, we only did this having feeling confident that the release candidate process had been long enough. We prefer to release early and often, and with the help of people like you, the quality will get higher and higher.

You'll also appreciate that with ensuing major versions of SilverStripe, we will have a more strict process of 'feature lock' before the first RC. You see this at ...


Community Member, 24 Posts

5 December 2007 at 2:32am

I am an idiot.

I am ashamed to say I appear to have made a silly mistake and blamed you for it.

The problem that kept popping up was that I had duplicate files on the server. This occurred because for some reason some files were left behind when I deleted the RC. :(

I am not embarrassed about the mistake, any noob could have made it :) ... BUT I am sorry to have immediately complained here without further testing.

I am glad to say I got the site to work, and am very impressed so far. Still, some good has come out of this thread... thanks Sigurd, i'll join the mailing list right away. Thanks also Laktek, Fuzz10, and Tobbe. I appreciate the assistance.

I still have minor issues, such as needing 64MB mem to install SS, but I withdraw my earlier complaint about Silverstripe not being fit for 'stable' release. I'm sorry.


Google Summer of Code Hacker, 76 Posts

5 December 2007 at 1:14pm

marikas >> Please don't take this too personal and let's forget it. We all get disappointed like you when things doesn't work as expected. It's natural :)

It's great to hear that you will give your assistance to SilverStripe development. Let's join togethter and help to bring out a great product !

Go to Top