Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Got login problems after install?

Go to End

8 Posts   1647 Views


Community Member, 17 Posts

6 December 2007 at 8:05am

So, there seems to be a lot of problems with logging in after installing ... that's a shame.
There's lots of threads on this, but this one's a bit more specific - or at least I couldn't find a thread dealing with it ...

Anyway, I suffered the same problem as so many others, scoured the forums, checked out the FAQ (, and checked code and such ...

Background on my install: PHP (5.2.3) and MySQL (5.0.24a) ... typical LAMP.

Config all worked and .htaccess was fine ... no problems there ... reset the cache, blah blah blah ... all that ...

I noticed it worked in IE, but not in FF ... odd ...

Some other notes:

- tried entering the obviously wrong password and bumps back with an error message saying so (ok, just testing to make sure that that is working)

- tried 'reset your password', doh! my 'email' is currently just admin, so go into the db through phpMyAdmin and set it to my email address.

- received the 'reset password' email, but when I follow the link I get a message saying "You must be logged in in order to change your password!" ... umm ... this is a side issue, but to reset my password, it generally means I don't know what it is, so how can I log in to reset it if I don't know what it is .... yeah ... growing pains of a system, I understand, no worries.

I had always suspected it might be the cookies ... so in to FF I delved ...

Ok, this rant is long enough, I'll jump to the ending: for some reason I had competing cookies vying for the same position with respect to domain & name. Very odd, not sure how that came about. I suspect it could've been that one of the cookies was set when I first tried logging in (and before resetting the cache). Or possibly a competing app because I also have Drupal installed, although that doesn't make sense because they have different names.

But anyway, something odd was happening with the cookies ... still not sure what, but yeah, try clearing your cookies, specific to your install's domain (base & sub-domains). I've got a very customized FF install, so there could've been some conflicting issues there as well.

Whew, that was long winded, sorry 'bout that ...

Oh yeah, and something needs to be done about that "You must be logged in in order to change your password!" issue.


Community Member, 201 Posts

6 December 2007 at 9:58am

I've added a ticket for the password reset issues at


Community Member, 17 Posts

6 December 2007 at 11:50am

Kia ora Tim ... sounds good.

I... am an enchanter.
There are some who call me... 'Tim'

heh, couldn't resist.


Community Member, 201 Posts

6 December 2007 at 12:33pm

Hey KumaZatheef

It would be fantastic if you're able to replicate, and document the login error - it's a pretty important one to fix however we can replicate it at all currently.

- Tim


Community Member, 17 Posts

6 December 2007 at 1:02pm

Edited: 16/08/2011 6:45pm


I'll see what I can do.


Community Member, 17 Posts

7 December 2007 at 12:22pm

Yup, it's definitely possible to replicate it ... .although, I think it may have something to do with my current Drupal install.

The setup:

I've got Drupal installed at the base domain:
Currently, I've got SS installed on the sub-domain:
(I'm playing around & setting up SS before I switch over).

In checking FF's cookies, Drupal goes as follows:
Path: /

Whereas SS goes as follows:
Path: /

What I immediately find odd is that SS uses "Host", whereas Drupal uses "Domain".
EDIT: My bad, after some more digging, there's a correlation: "Domain" only seems to be used when it's value begins with a period '.' ... so that's probably not the issue.

The way I replicate this (after clearing the cookies belonging to '') is by simply signing in to my Drupal install, then attempting to sign in to SS. If I clear the cookies, sign in to SS, then Drupal, everything's as it should be.

Best solution: Don't have SS on a sub-domain where the base domain has Drupal. ;-)

But in all seriousness, I'll do a little more digging and see what I can come up with ... otherwise this seems like Drupal is trumping SS, so most likely a non-issue.

Anonymous user

2 Posts

9 December 2007 at 12:34pm

I have had the same problems also. Have also had the problem of all the users including the default dissapearing in the security page. Same as all the other entries on that thread. The members are in the database but will not show. However, now can not get log in to work at all. Have tried all suggestions (upgrade database, try different browser) none work. Have found when installed to WAMP on Windows all works OK. Can not get SS to go on Linux at all. By the way I have Ubuntu 6.1 Linux. Could this make a difference?


Community Member, 17 Posts

14 December 2007 at 5:54pm

You have Drupal installed?