Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Translation defaults


Go to End


6 Posts   2196 Views

Avatar
OzziNL

Community Member, 37 Posts

7 December 2007 at 11:41pm

Hi there,
Working for a week now with SS and so far: love it!

I have a question about multi language sites. I managed to default the CMS to dutch.
But the site I'm working on is default dutch (nl_NL).
The system however is en_EN and I can add only dutch as "translated pages". Is there a way to make nl_NL my default and to add English as a translation?

I hope I explained my problem clearly ... :)

Thanks in advance

Avatar
guillem_l

9 Posts

11 December 2007 at 6:03am

Hi,

I have the same question, how to set the default language to Catalan insted of English, for example, and how to delete a Translation after created it.

Thanks.

Avatar
Pasquale

Community Member, 3 Posts

11 December 2007 at 11:44am

I Have a site with 3 languages. When I create a page in english it doesn't apear in Spanish or Catalan tree menu.

Avatar
Ingo

Forum Moderator, 801 Posts

13 December 2007 at 10:55am

@ozzi/guillem: you can configure the default website language by setting
i18n::set_default_lang('de'); // for german
i've updated the wiki: http://doc.silverstripe.com/doku.php?id=multilingualcontent

@pasquale: a new page doesn't have all translated languages by default, you have to explicitly create them for each page.

Avatar
OzziNL

Community Member, 37 Posts

13 December 2007 at 11:00am

Great! I'll give it a try!

Thanks

Avatar
guillem_l

9 Posts

13 December 2007 at 11:08am

thanks! Works form me.