Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

new hosting provider, new challenge

Go to End

14 Posts   3315 Views


Community Member, 791 Posts

13 December 2007 at 11:33pm

This probably will not help you very much, but we've had _major_ problems running Silverstripe on PHP 5.1.2. Don't know about older versions. But from 5.1.6 on we've had no problems.


Community Member, 32 Posts

14 December 2007 at 12:25am

Hello Fuzz10

Strike! Thanks for your hint.

The Problem was caused from the php version < 5.1.x
After upgrading (add parameter to .htaccess) the php version to 5.2.2 the website appear!

But now I have the famous memory problem :-)
Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 4980736 bytes).

I've tried to set ini_set("memory_limit","32M"); in sapphire/main.php without any success. After a few reload the site works if I don't use ?flush=1

Although with php 5.2.2 I still have the sitemap.xml issue with a new error:
FATAL ERROR: No current controller available
At line 329 in .../sapphire/core/control/Controller.php

Anybody an idea?




Community Member, 501 Posts

14 December 2007 at 1:19am

Try setting it to 64mb.

I've heard that the latest version requires more than 32mb. (This might be only when installing though.)

Alternatively try setting the memorylimit in your htaccess file:

php_value memory_limit 64M


Community Member, 791 Posts

14 December 2007 at 2:16am

Glad to hear it runs ; I know how aggravating it can be losing a lot of time getting something online. ;-) I guess it is pretty safe to say Silverstripe _needs_ PHP > 5.1.2 and > 32MB scriptmem.

Very weird error ... You don't happen to accidentally have a conflicting page or class called Sitemap ?


Community Member, 32 Posts

14 December 2007 at 3:04am

Hello guys

Thanks for your great support! It works now!

Step by step we come to the point and by the way we detect some interesting facts :-)

I've changed the saphire/main.php value from 32 to 64

and also adapted the .htaccess from 32 to 64
php_value memory_limit 64M

* * * * * * *
The sitemap.xml issue still persist. I've checked the page names and classes.
No doublets at all. But I have news!
I have figured out that when I changed the set_environment_type parameter in my _config.php from dev to live or remove it, the FATAL ERROR doesn't occure anymore.
Director::set_environment_type("live"); instead I have a new FATAL ERROR :-)

Fatal error: Call to a member function getSession() on a non-object in .../sapphire/core/Session.php on line 32

God bless the session();



Community Member, 32 Posts

14 December 2007 at 10:45pm

Update on sitemap.xml

I've installed the new release candidate 2.2.1 rc1

and the sitemap rocks!!

Thanks all


Go to Top