Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Can't upload images

Go to End

66 Posts   403047 Views


Community Member, 75 Posts

30 April 2008 at 11:51pm

I have had a similar problem with uploading images files with the tinymce. Everything was fine on my own developing-server - I only had the problems when I launched the Project by my provider.
I guess it might be a server caching problem!
I solved it by uploading files from the Files&Images Section. Sometimes I had to clear the browser cache too - but it's still strange.


Community Member, 22 Posts

16 May 2008 at 1:45pm

I'm using the Daily Build 2008-05-15 and have no luck to get the file upload part working...

The installation went well with this (on Web Drive hosting) and it's edging close to working condition except the file upload!!!

Any solution to why the file upload appeared to be working with the progress bar filled, but when checked via FTP, no file uploaded at Assets, and neither it shows up in the File and Images section either. Asset has 775 permissions.


Community Member, 22 Posts

19 May 2008 at 10:10pm


Is anyone looking into this?


Community Member, 22 Posts

21 May 2008 at 9:38am

Edited: 21/05/2008 9:39am

I have created a new ticket for this #2524.

2.2.2rc5 does have the latest version of SWFupload which unfortunately doesn't fix the problem.
In the meantime its possible to upload files and images into the assets directory via ftp, then when clicking on the File and Images tab within Silverstripe it'll parse that directory and make them available.


Community Member, 22 Posts

21 May 2008 at 12:30pm

I know it is possible to FTP the files but the authors that will be using the site that i'm testing for will not 1) understand how to use FTP, 2) prefer not to have to fumble with FTP and 3) not as easy and as "portable" to make changes and/or upload necessary file(s) from anywhere with Internet.

I do hope to see file upload module be fixed soon in the next daily build.

At the moment, I'm back on Drupal for testing their CMS.


Community Member, 9 Posts

22 May 2008 at 5:37am

Edited: 23/05/2008 7:24am

I have just done the 5 tutorials and got things done except for the image uploading feature for the CMS as shown in tutorial 2 (StaffPage).

On a StaffPage in the CMS I get the additional Image-Tab but in there it displays the complete Page-Not-Found-Page in place of the Form with image-upload and -selection fields.

I found that my problem had nothing to do with image-upload.
It had to do with mod_rewrite of url string for getting the image form.


Community Member, 7 Posts

22 May 2008 at 9:22am

Edited: 22/05/2008 10:34am

The problem is flash player 9.0.124. Downgraded to 9.0.48 and now it works.

Update: After some more testing I recommend to avoid flash player 9 completely. Use version 8 available on


Community Member, 22 Posts

22 May 2008 at 12:44pm

Does work for you?

If you download SWFupload from and run the swfupload/demos/applicationdemo does that work on your server?