Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Installation problem

Go to End

8 Posts   3670 Views


Community Member, 8 Posts

10 January 2008 at 2:53am

i've got a big problem where i dont find a way out. when trying to install there comes the following error:

Is the .htaccess file writeable?

User 'user' needs to write be able to write to this file:

this error occures also for the mysite/ tutorial/ and the assets/ folders...

can anyone tell me what to do now?



Community Member, 32 Posts

10 January 2008 at 4:35am

Hello Michi

As the error already says, do you have write permission to the .htaccess file in the folder

Please check your permissions for the file and folder/subfolder mentioned.
If you have only read permission change it and reinstall SS.

Good luck



Community Member, 8 Posts

10 January 2008 at 5:01am

do you mean the settings in one of the silverstripe files or the server peimissions?
if it helps: i have the tar.gz installed


Community Member, 8 Posts

16 February 2008 at 11:50pm

I'd like to know an answer to this one too - I've tried changing the permissions on the files/folder via windows and it always reverts to read-only, i've tried to change the Apache config file... still no joy - i'd really like to be able to get SilverStripe up an running but i find myself stuck with the same problem - being new to building and hosting websites isn't helping either... but with a little help i'll get there...




Community Member, 1 Post

11 March 2008 at 5:08am

I have kind of the same problem. I'm running XAMPP 1.6.6 (Apache 2.2.8, PHP 5.2.5 and MySql 5.0.51) on Vista Ultimate and the Silverstripe version is 2.2.1.

I've checked that I have full permissions to my Silverstripe-directory and all the files in it.

Still the install screen complains:

Unable to detect whether I can write to files. Please ensure C:/xampp/htdocs/ss1/.htaccess is writable.

And the same with "C:/xampp/htdocs/ss1/mysite", "C:/xampp/htdocs/ss1/tutorial" and "C:/xampp/htdocs/ss1/assets".

I've enabled mod_rewrite in Apache and it gives this error message when trying to install:

# ERROR: mod_rewrite not working, redirecting to mod_rewrite test page
I will now try and direct you to rewritetest to troubleshoot mod_rewrite

After that it loads the rewritetest.php but doesn't output anything.


Administrator, 690 Posts

11 March 2008 at 11:07am

SilverStripe 2.2.2-rc2 will be out very shortly, and it should fix this problem.

Stay tuned at


Community Member, 20 Posts

14 July 2008 at 5:06pm

"Administrators" and "SYSTEM" have the "Full Control" permissions.

Who else needs it to satisfy the "is writable" criteria?

i.e. I don't want to go overboard and select "Everyone" if I don't need to.


Administrator, 690 Posts

18 July 2008 at 3:00pm

The user that runs your webserver needs to be able to, at least while you are installing.