Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

How to disable PHPSESSID?

Go to End

2 Posts   2163 Views


Community Member, 2 Posts

21 January 2008 at 10:15pm

I would like to know, if there is a solution to rewrite the url any time, especially for the PHPSESSID. Normally you can see this ID for just 10 clicks or something like that and than it gets "rewrite". But also google for example lists any page with /PHPSESSID1234... at the end. I recognized, that this ID isn't shown on so I suppose that this is just an adjustment, isn't it? Sorry for the bad English...


Community Member, 2 Posts

21 January 2008 at 11:37pm

Problem fixed! Obviously, this thread was displaced in this forum. But for all other noobs with this problem I will post the solution.
You have to add this "php_flag session.use_trans_sid off" to your .ataccess file and PHPSESSID is disabled. There might be some problems with user auth. when cookies are disabled...