Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Install Hangs On Parser Error

Go to End

4 Posts   1754 Views


Community Member, 3 Posts

29 March 2007 at 11:36am

I'm trying to install SS on my Win XP Pro system. It currently has XAMPP running with Joomla and ZenCart. These applications are working fine. I placed the SS folders/files in the htdocs folder and navigated to http://localhost/silverstripe-v2.0/install.php.

The install check is all OK except for "Memory allocated (PHP config option 'memory_limit')". I edited php.ini to the recommended 32M and retried install but no luck. Get the same memory error msg.
Next scrolled back to the top of the install check page and selected "Please reinstall..." and clicked the Install button.

The Installing SilverStripe page appears but installation stops with the following error msg just below Building database schema...,
"Parse error: syntax error, unexpected T_IF in C:\JoomlaStarterKit\htdocs\silverstripe-v2.0\sapphire\core\SSViewer.php on line 219"

Anyone have any idea what may be causing this install hang?



Forum Moderator, 628 Posts

29 March 2007 at 8:10pm

make sure your files are properly extracted? seem to have a few people with issues around that, with a few files missing. is every file from 'sapphire' in your targz actually sitting on your website now?

also, see if the 2.0.1 beta gives you more luck; it doesn't seem like it has created any more bugs, only fixed most of the main ones from 2.0.0.


Community Member, 3 Posts

29 March 2007 at 11:56pm

Downloaded/extracted silverstripe-v2.0.1-rc2.tar.gz. Getting the exact same response posted in original post. Same number of files in the two separate 'sapphire' folders also.

Tried extracting with both WinZip and ZipGenius to see if there was a snafu there, but did't make any difference.

So, guess I'm out of luck with this OS partition. Will restore another XP on separate partition and try the windows SS installer with php instead of XAMPP that came with the Joomla package.



Community Member, 3 Posts

30 March 2007 at 2:47am

Sigurd, I tried but no joy:

Ran the windows all in one install on the fresh XP SP2 partition. The install went through its steps without a glitch. Then opened the CMS admin and it asked me to login. Tried admin and password, no go. Opened _config.php in mysite and found this,

global $project;
$project = 'mysite';

$databaseConfig = array(
"type" => "MySQLDatabase",
"username" => "root",
"password" => "",
"database" => "SS_mysite",
"server" => "localhost:3307",


? root and no password ? I'm now absolutely positive I don't know enough to get SS up and running and pretty much convinced I never will.