Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Allowed memory size exhausted


Go to End


2 Posts   2094 Views

Avatar
StarsandStripes

Community Member, 4 Posts

6 March 2008 at 1:02pm

Edited: 06/03/2008 1:03pm

Hi! I've checked the forums and increased the memory to 64M using a PHP.INI-file in the same directory as config.php. But then I got stuck with the message below.

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 19456 bytes) in /silverstripehome/cms/code/Newsletter/NewsletterType.php on line 75

I tried to store a PHP.INI in the Newsletter directory, but that just doesn't cut it.
Any clues?

Avatar
saimo

Community Member, 67 Posts

7 March 2008 at 1:17am

8388608 bytes == 8Mb which means that your memory setting isn't working. The normal way of setting this is in your .htaccess file. Add the following line to the top of the file:

php_value memory_limit 128M

to set it to 128Mb. If that doesn't work you may try to set it in sapphire/main.php but I don't remember the function name to set it using php. Search php.net.