Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Opera 9 Throws Error...

Go to End

3 Posts   1938 Views


Community Member, 1 Post

5 April 2007 at 6:44am

Edited: 05/04/2007 6:51am

I recently come across silverstripe and like everything I've seen.

Initially, I downloaded the windows installer of "2.0 Stable", installed it and ran it. Silverstripe was then running very well except the file upload section of the admin area.

This happened, no matter what browser I tried. I managed to solve that by upgrading it to the RC3 yesterday. I just untarred / gzipped the source files and copied them over the existing PHP scripts. If I missed a step, let me know.

However, merely navigating the asset tree was enough to make Opera v9 popup script failed to execute dialog complaining an inability to translate a null value to an object.

Using Opera 9 and while trying to navigate the asset tree in the file upload section of the Admin area is all it took for me to repeatedly reproduce this problem. Hopefully, you will see it easily should you or anyone try it.

I have XP, I use Opera where possible which is the only browser I can get to produce this error box. I also have IE, Firefox, and Safari available but again they work without fail (as far as my limited testing has thus far revealed).

While the simple solution is just not to use (or support) Opera, I was wondering if anyone else has experienced this and whether it will be something that is fixed assumming it's reproducible by you guys.

It's overall an excellent CMS so far. Great Job! :)


Forum Moderator, 922 Posts

5 April 2007 at 9:32am

In my testing I've used mostly Firefox and some Safari/IE6 & 7 - however haven't tried Opera yet.

Thanks for pointing this out, sometime today I'll install Opera 9 and see if I can reproduce the bug myself. :-)



Forum Moderator, 922 Posts

5 April 2007 at 9:56am

Edited: 05/04/2007 9:56am

I got the error. There's a lot of backtrace which is quite nice. I've added this as a bug to our issue tracker. Thanks for the report! Hope you're liking the CMS. :-)