Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Local Installation stuck on mod_rewrite not working


Go to End


12 Posts   5366 Views

Avatar
Lucy

Community Member, 2 Posts

13 March 2008 at 2:05am

Edited: 13/03/2008 2:05am

Hi all:
Have just attempted to install using the PHP installer on a local webserver running:

Apache 2.2
PHP 5.2.4
MySQL 5.0

OS - Vista home premium
Browser - FireFox

The installation window doesn't seem to see the loosened write permissions as it tells me it is unable to detect whether it can write to these files/folder:

.htaccess
/mysite
/tutorial
/assets

However - I did open up these permissions so went ahead with the install, which was able to write to the .htaccess and create_config files so I think they're OK.

But then I get the mod_rewrite not working message, and it connects me to rewritetest.php which takes a good long time to load and then is a completely blank page.

When I view the SS directory in my browser now I get the install page again, which asks me if I want to overwrite the current install.

I have uncommented the mod_rewrite in the apache conf file. But not sure how to enable AllowOverride. When I tried adding this for the SS directory Apache kept giving error messages. Also, when I tried adding the server.error-handler-404 = “/sapphire/main.php” as suggested I could not get apache to start.

Having gone through this three times now I'm admitting defeat. I'm sure the problem lies with my lack of knowledge in just exactly how I should be changing the apache conf file...

I also think I read somewhere that FF may be a problem and I should use IE7 instead for the install process? But I may have dreamt that up - my head is spinning at this point.

Thanks in advance for your help!

Botticelli's Venus? Well - it was going to be a long boring post and I thought she might help keep you interested!

Avatar
samozin

Community Member, 3 Posts

13 March 2008 at 10:10pm

the same prob here any one can help

Avatar
Lucy

Community Member, 2 Posts

15 March 2008 at 11:31am

Can anyone confirm that the latest release does, in fact, address this issue?
please?

Avatar
cames

Community Member, 9 Posts

15 March 2008 at 12:16pm

Try the daily build for 8th March (the last one I tried) here:

http://dailybuilds.silverstripe.com/core-tarballs/

or try this post:

http://www.silverstripe.com/site-builders-forum/flat/41092#post41648

If it works in the daily build, it should be safe to assume it's fixed in SilverStripe 2.2.2rc2 just released?

Avatar
sharper

Community Member, 7 Posts

16 March 2008 at 7:07am

were any of you guys able to find a solution to this problem? i've been at this for a week now with no success.

Avatar
cames

Community Member, 9 Posts

16 March 2008 at 9:21am

silverstripe-v2.2.2-rc2 works for me - I've experienced the errors before, but the install test in v2.2.2 rc2 now correctly reports mod_rewrite for Apache2.2 on both Windows and Linux servers.

What's your setup?

Avatar
sharper

Community Member, 7 Posts

16 March 2008 at 9:32am

Edited: 16/03/2008 10:43am

i'm attempting to install on a remote server (my hosting company's mediatemple). it's a unix server running apache/2.0.54, MySQL 4.1.11 and php 5.2.5

Avatar
squeezynemo

Community Member, 1 Post

16 March 2008 at 10:23am

hi guys

I need some help i'm installing the ss but i always have this problems

Details
Does the server exist OK (localhost)
Are the access credentials correct OK
MySQL version at least 4.1 OK (MySQL 5.0.27)
Can I access/create the database I can't create new databases and the database 'kcfmnz_co_nz__allacess' doesn't exist (user 'kcfmnz' doesn't have CREATE DATABASE permissions.)

Server software I can't tell what webserver you are running. Without Apache I can't tell if mod_rewrite is enabled.
mod_rewrite enabled I can't tell whether mod_rewrite is running. You may need to configure a rewriting rule yourself.

Go to Top