Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Local Installation stuck on mod_rewrite not working

Go to End

12 Posts   5381 Views


Forum Moderator, 922 Posts

16 March 2008 at 10:43am

Edited: 16/03/2008 10:45am


1. It looks like you'll have to create the database yourself, since SS can't automatically do it.

2. Does the installation die after the "I can't tell whether mod_rewrite is running." notice? I would assume that because it didn't detect mod_rewrite, it wasn't able to properly make, if at all, the .htaccess file for this installation of SilverStripe.



Community Member, 7 Posts

16 March 2008 at 10:49am

i'm having a similar problem (my post is the one right before squeezynemo's). is there a fix or workaround. i'd really like to get ss up and running so that i can give it a try.


Community Member, 9 Posts

16 March 2008 at 1:15pm

Edited: 16/03/2008 11:57pm

sharper - I've dug out an old Apache 2.0.55 / PHP 5.1.2 server, and Silverstripe v2.2.2 rc2 installs OK.

This is a long shot, but - do you have any functions disabled in your php.ini?

Check 'disable_functions' towards the top of the standard phpinfo() output - if "apache_get_modules" is listed, you could end up with the error you report

Alternatively: Does your host run PHP as cgi? If so, you won't have the apache2handler functions to return the available modules, so the installer tells the truth, if not the full story. Complete the install anyway, and check your .htaccess file - the rewrite rules should still get written and Silverstripe should be fine.


Community Member, 7 Posts

17 March 2008 at 8:17am

thanks. i solved the problem by deleted the database and creating a new one. all is well in the world.

Go to Top