Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Trivial Patch Attached: Improves Clearity of mod_rewrite not enabled error message

Go to End

4 Posts   2796 Views


Google Summer of Code Hacker, 222 Posts

6 April 2007 at 4:20pm

Hi Guys,

I have a simple language string change that I'd like to request.

Please replace this line (line #122) in install.php:

$this->requireApacheModule('mod_rewrite', array("Webserver Configuration", "mod_rewrite enabled", "You need mod_rewrite to run SilverStripe CMS."));

with this:

$this->requireApacheModule('mod_rewrite', array("Webserver Configuration", "Is mod_rewrite enabled?", "Error: You need mod_rewrite to run SilverStripe CMS, but it is not enabled."));

The way it is currently phrased, I was at first unsure if the error message was really saying that mod_rewrite was not enabled.

Just wanting to help out some. :)


Elijah Lofgren


Community Member, 231 Posts

11 April 2007 at 11:30am

Yeah, probably needs to be clarified some. Patch is applied and will be in 2.0.1. Cheers!


Forum Moderator, 628 Posts

11 April 2007 at 7:33pm

Thanks Elijah. Its awesome to see Google Summer of Code applicants like yourself supplying patches and your contributions are now downloadable in the daily builds and in 201rc6...

Its key for us to make the installation of SilverStripe a breeze, so this sort of tweaking is well worth informing us about :)


Community Member, 57 Posts

7 March 2008 at 6:00pm

I have run into a problem while running the PHP installer.

When the installer initially checks for the ability to mod_rewrite it reports that it is OK. However at the end of the install, it reports that mod_rewrite dos not appear to be working. Have tried completely clean installs a number of times and have come up with the same error. After refreshing the browser, it goes back to square one of the installation. Eventually, comes up with the following error message:

mod_rewrite doesn't appear to be working. Make sure:

- mod_rewrite is enabled in your httpf.conf
- AllowOverride is enabled for the current path.

Please check these options, then refresh this page. If you believe that your configuration is correct, click here to proceed anyway.

When you click on the "click here" link it reports that forced install completed and then displays the Installation Successful page.

when you click to delete the install file, it cannot delete them.

When you click to go into the CMS, it does not accept the login and password details you ahd entered. So unable to go into site editing.

Can someone assist in finding out what is wrong and how can I get access to editing the CMS