Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Check-php.php error...

Go to End

7 Posts   29874 Views


Community Member, 2 Posts

27 March 2008 at 1:07pm


Every time I go into my site ( it gives me an HTTP 404 Not Found Error and changes the url to

but when i add the ?flush=1 it works fine

any ideas on whats wrong?



Community Member, 5 Posts

27 March 2008 at 1:40pm

Check if you're running PHP 5.0 or higher.


Community Member, 2 Posts

27 March 2008 at 2:01pm

yea Im running PHP version 5.2.3 ...


Community Member, 1 Post

6 May 2008 at 7:15pm

clear your cache completely, or try reloading the homepage after disabling Javascript.


Community Member, 3 Posts

18 June 2008 at 10:13am

Edited: 18/06/2008 10:51am

Scratch that, cleared cached in FF 3.0 and it is working, the problem has been resolved since RC3

(still can't quite shake the feeling that it's something I'm doing wrong, though...)

For what it's worth, I'm getting this problem as well, but only from Firefox 3.0... FF 2.0 and IE are working OK.

If I disable Javascript in Firefox 3.0 and reload, instead of getting back a 404 re: check-php.php, I get a simple page with a link to install.php.

I have had to remove "DirectorySlash Off" from .htaccess to allow browsing to as well. (was failing with 403 forbidden before that)

I'm using PHP 5.2.5 and Apache 2.2.

A coworker has an account on the same webserver, and hers works fine in all browsers, with no hacks made to .htaccess either, so I'm really puzzled as to what I'm doing wrong. The only difference is our installation methods (she uploaded via FTP and extracted using her supplied file manager while I was lazy and wget'd/untar'd from a shell) and that hers is running in her document root, while mine is running in a subdirectory of my document root.

I know I've got to be doing something stupid, and I will keep looking, but if someone could throw me a clue I'd be very grateful ;)



Community Member, 14 Posts

13 August 2008 at 4:03am

Hey Cynic!

Got the same Problem here...
I have no idea why it isn't working.
I made 5 SS Pages now and never had a Prob, but my newest Project won't work under FF3.
Works fine under Safari, though!

You found a solution for the Problem?
I would be interested as well.



Community Member, 21 Posts

12 November 2008 at 6:25pm

Yup the fix is just clearing the cache of your browse. You can't do a hard refresh of the page - because you cant open the page... So remove cache and then works fine =)