Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Installation problem (provider)


Go to End


2 Posts   1449 Views

Avatar
vektor7

Community Member, 2 Posts

30 March 2008 at 10:15am

I installed silverstripe local successfully. After that I tried an installation on my providers server. The installation stopped with the following messages:

-----------------------------------------
Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation
# Creating 'mysite/_config.php'...
# Creating '.htaccess' file...
# Building database schema...
-------------------------------------------------

Server: Apache
PHP: 5.2.5
MySql: 4?

Thanks for any help.

Avatar
vektor7

Community Member, 2 Posts

31 March 2008 at 9:10pm

Problem solved:
After reading the server requirements: http://doc.silverstripe.com/doku.php?id=server-requirements#php
I asked my provider to upgrade the memory_limit from 20M to 32M. After this the installation runs perfect.
The advertised work around to increase the maximum memory by adding a “ini_set(”memory_limit”,”32M”);” line to sapphire/main.php didn't work. I think the provider do not support the dynamicly adjusting of ini settings.