Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Error in Ajax evaluator on line 977


Go to End


1508 Views

Avatar
phptek

Community Member, 15 Posts

1 April 2008 at 1:47pm

Edited: 03/04/2008 2:48pm

Reproduce:

* Select any page-title in the left-hand pane under: "Site Content and Structure".
* Bring up "Page version history" in the left-hand panel.
* Check 1 or both checkboxes
* Select any 2 revisions
* Press "Save and Publish" button
* Major error is main-pane, which shows up HTML input boxes among the error-text (see screenshot at: http://www.theruss.com/images/ss-screenshot.jpg)

Error in Ajax evaluator on line 977: $("Form_EditForm").elements.StageURLSegment has no properties $('Form_EditForm').loadActionsFromString('\n \n \n \n '); $('Form_EditForm').loadActionsFromString('\n \n \n \n '); $('Form_EditForm').updateStatus('Published'); $('sitetree').setNodeTitle(4, ' Page not found ') $('Form_EditForm').elements.StageURLSegment.value = 'http://cannon.gns.cri.nz/silverstripe/-page-not-found-/' $('Form_EditForm').elements.LiveURLSegment.value = 'http://cannon.gns.cri.nz/silverstripe/-page-not-found-/' $('Form_EditForm').notify('PagePublished', $('Form_EditForm').elements.ID.value); statusMessage('Published \' Page not found \' successfully', 'good');