Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo


Go to End

3 Posts   4439 Views


Community Member, 2 Posts

2 April 2008 at 4:18pm

Hi. I've just installed Silverstripe for the first time.

Before I knew that I had to up the PHP memory_limit to 32M, I fiddled a bit with the main.php file in sapphire directory. I inserted the suggested line to up the memory size there to 80MB. After I realized my error, I configured php.ini to use 32MB instead of the default 16MB and deleted the mem line from main.php. But I still get the error:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 4980736 bytes) in /tmp/silverstripe-cache-var-www-silverstripe2/cache.php on line 4.

Clearly there is something stored somewhere from when I had a bigger mem size in main.php.

I tried to delete the cache.php but that didn't help as it's recreated the next time I open the "silverstripe2/home/successfullyinstalled?flush=1" address. I even rebooted my server to see if it would help. But no. How can I make SilverStripe understand it should use the default 32MB size instead of that 50MB it got from somewhere?


Community Member, 473 Posts

2 April 2008 at 4:32pm

"Allowed memory size of 33554432 bytes exhausted"

33554432 bytes == 32 MB

"tried to allocate 4980736 bytes"

4980736 bytes == 4.75 MB

It's not using 50 MB anywhere, though you may want to increase you limit as it appears that 32 MB isn't enough for the function you're running.


Community Member, 2 Posts

3 April 2008 at 12:12pm

Thank you for pointing out my error. Now SilverStripe works perfectly. I like it a lot ! :)