Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Gallery Navigation Bug


Go to End


2 Posts   1707 Views

Avatar
Liam

Community Member, 470 Posts

8 April 2008 at 1:12pm

Running the latest 2.2.2 rc2 version of SilverStripe with the stable version of gallery.

peregrineinternational.ca/photos/ (can't directly link for referrer reasons)

If you take a look at the page, you'll see the navigation bar is messed up. It seems to be taking the last image on the next/previous page of a multi page gallery, and throwing a link to them in those square boxes. View the screenshot if you don't want to directly see the site.

Has this ever happened to anybody? The only thing I can think of, is that I had to upload the photos through FTP into the folder, as there is a current upload bug with the latest rc version of SS, and I couldn't upload through the admin area. I don't think that would effect it though.

Avatar
Liam

Community Member, 470 Posts

9 April 2008 at 11:55am

Has anybody run the Gallery module with rc2? It's a coding issue, because I haven't touched the gallery templates much.

Here is the code it is outputting for the navigation bar:

<div id="NavigationBar">
<a id="ViewLink-69" class="lightwindow" caption="800 x 533 - 57 KB" title="science teachers 2.jpg" href="/assets/photos/_resampled/ResizeRatio600600-science teachers 2.jpg" rel="Photos[Media]"/>
<div id="Previous">link stuff here</div>
<a id="ViewLink-69" class="lightwindow" caption="800 x 533 - 57 KB" title="science teachers 2.jpg" href="/assets/photos/_resampled/ResizeRatio600600-science teachers 2.jpg" rel="Photos[Media]"/>
<div id="PageNumbers">link stuff here</div>
<div id="Next">
</div>
<div class="clear"></div>

I've edited out the good code, but left the div wrapper so you can see. The stuff in bold is extra code being produced out of place.

http://www.peregrineinternational.ca/photos/