Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

imageupload not showing new uploaded images

Go to End

4 Posts   2486 Views


Community Member, 7 Posts

15 April 2008 at 9:46am

Edited: 16/04/2008 9:14am

For some reason when I click on the image upload button on the editor it's not showing me the image I just uploaded, it never has done.

I tried to upload it a number of times, I could see it adding the files when I looked via ftp, as filenameN.jpg, in "assets/Uploads/" so it was clearly uploading correctly.

It seems like a caching issue, if it is, this is a bug...

Any ideas on how to resolve this?


Community Member, 29 Posts

19 April 2008 at 7:53pm

I'm seeing the same problem ...
Upload via the GUI, they are listed in the directory,
but viewing details window is empty.
If I try & add them to a page ,
the page does not show them.
The GUI for adding images to a page just says "Error getting files"
.. is this how you see it?


Community Member, 29 Posts

19 April 2008 at 8:31pm

httpd/error_log shows the following:
[Sat Apr 19 20:23:59 2008] [error] [client] PHP Fatal error: Call to undefined function imagecreatefrompng() in /export/home/nzcoop/www/sapphire/filesystem/GD.php on line 22, referer:

This was after using the gui to
1. I created a new directory
2. uploaded a file
3. tried to see the details of the file.

The file was created & the underlying permissions are okay:
[root@server assets]# ls -l
total 24
-rw-r--r-- 1 apache users 2147 2008-04-08 14:37 error-404.html
drwxrwsr-x 2 apache apache 4096 2008-04-19 19:32 images
drwxrwsr-x 2 apache apache 4096 2008-04-19 20:22 NewFolder
drwxr-xr-x 2 apache users 4096 2008-04-19 19:23 Uploads
[root@ server assets]# ls -l NewFolder/
total 64
-rw-r--r-- 1 apache apache 57909 2008-04-19 20:22 dumb.jpg
[root@ server assets]#


Administrator, 690 Posts

21 April 2008 at 1:05pm

Looks like you don't have php-gd2 installed. It's an extension for PHP.

Get that installed and it should work.