Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Installation Issue

Go to End

3 Posts   1783 Views


Community Member, 23 Posts

19 April 2007 at 2:36pm

Edited: 19/04/2007 2:37pm

I just installed version 2.0.1 on my remote server and I'm getting these messages, first:

mod_rewrite doesn't appear to be working. Make sure:

* mod_rewrite is enabled in your httpd.conf
* AllowOverride is enabled for the current path.

Please check these options, then refresh this page.If you believe that your configuration is correct, click here to proceed anyway.

Then when I click the link to proceed, I get:

Forced continue, attempting to redirect to home/successfullyinstalled

It then immediately refreshes to a page with a Not Found error that says that sapphire/main.php was not found and that a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. Everything was fine with the install up until this point there were no warnings in the check once I specified the correct database info.

I verified that mod_rewrite is enabled. I do not have access to make Apache configuration changes. What should I do?


Community Member, 231 Posts

19 April 2007 at 3:39pm

Some people have had success by changing the last line of their .htaccess file from

RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]

to one with their absolute path in it like:

RewriteRule .* /webroot/silverstripe-v2.0/sapphire/main.php?url=%1&%{QUERY_STRING} [L]

swapping webroot for where you have silverstripe installed.


Community Member, 23 Posts

19 April 2007 at 4:23pm

Thanks. Making that correction fixed it. I think the problem is that I just signed up for this hosting account and I have to access it with a temporary url. It took trial and error. But it worked when I used everything that appears between "" and "silverstripe/saphire/main.php" from the temporary url to modify my .htaccess file as you suggested. Thanks for your help.

I'll probably have to set it back to normal after my domain name has propagated and I can start using it instead of the temp url.

Thanks again.