Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

google-indexing and phpsessionid - in FireFox not wellformed XML


Go to End


3 Posts   3348 Views

Avatar
zyko

Community Member, 66 Posts

14 May 2008 at 5:42am

Edited: 15/05/2008 7:58pm

if you search in google for fe:
silverstripe ?PHPSESSID

you'll find in 3rd result a link to
http://scb-judo.de/sample-blog-entry?PHPSESSID=286e901cb73dd0194b48e2371eff26d1

if you open this link in firefox, you'll see the same problem i've seen on my page.
(this one is not mine!)

XML-Verarbeitungsfehler: nicht wohlgeformt
Adresse: http://scb-judo.de/sample-blog-entry?PHPSESSID=286e901cb73dd0194b48e2371eff26d1
Zeile Nr. 71, Spalte 37:		<a href="/blog/?tag=blog&PHPSESSID=286e901cb73dd0194b48e2371eff26d1" class="not-popular">blog</a> 

it seems to me, that there should be no & and this should be replaced by
&amp;
to be wellformed in xml.
btw: this link comes from using (a href="#") tiltle="")mytilte(/a) in the template i think...

but i'm wondering what that PHPSESSID= setting at all has todo in an ss-website.
is there a possibility to get that away from google-index?

is there a solution to get rid of this bug?

g
helmut

btw: if you look at this page in InternetExplorer, you can see how blog-comments without any spam-protection in ss would be.
aaarghhh...

Avatar
Sam

Administrator, 690 Posts

15 May 2008 at 1:25pm

Avatar
zyko

Community Member, 66 Posts

15 May 2008 at 7:54pm

Edited: 15/05/2008 7:56pm

THX for the info, i'll give that a try.

Meanwhile i had the same problem, if i give back an url
from one of my DataObject-functions.
fe:

function GetGeoCodeUrl() {
  return "http://maps.google.at/maps?f=q&hl=de&geocode=&q=4400";
}

then i use this in my controller-template

  controller xxxx
    $GetGeoCodeUrl
  ...

this shows the same error as mentioned above.

so better is to code the & sign as it should be in XML!

function GetGeoCodeUrl() {
  return "http://maps.google.at/maps?f=q&amp;hl=de&amp;geocode=&amp;q=4400";
}

maybe this thing was'nt too clear till now...